PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Sauve l'image présente :
  • WINDEV dans un champ Editeur d'images.
  • Versions 25 et supérieures
    dans une variable de type WDPic.
    Nouveauté 25
    dans une variable de type WDPic.
    dans une variable de type WDPic.
Versions 25 et supérieures
WEBDEV - Code Serveur Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Nouveauté 25
WEBDEV - Code Serveur Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
WEBDEV - Code Serveur Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Exemple
WINDEV
// Demande de sauvegarde de l'image présente dans un champ Editeur d'images
SI PicSauve(EI_MonEditeur) = Faux ALORS
Erreur(ErreurInfo())
FIN
Versions 25 et supérieures
MonImageWDPic est un WDPic
...
// Demande de sauvegarde de l'image
SI PicSauve(MonImageWDPic, "C:\temp\test.png") = Faux ALORS
Erreur(ErreurInfo())
FIN
Nouveauté 25
MonImageWDPic est un WDPic
...
// Demande de sauvegarde de l'image
SI PicSauve(MonImageWDPic, "C:\temp\test.png") = Faux ALORS
Erreur(ErreurInfo())
FIN
MonImageWDPic est un WDPic
...
// Demande de sauvegarde de l'image
SI PicSauve(MonImageWDPic, "C:\temp\test.png") = Faux ALORS
Erreur(ErreurInfo())
FIN
Syntaxe
<Résultat> = PicSauve(<Image> [, <Fichier>])
<Résultat> : Booléen
  • Vrai si l'image a été créée,
  • Faux dans le cas contraire (erreur, annulation du sélecteur de fichier, ...). En cas d'erreur, la variable ErreurDétectée est à Vrai et la fonction ErreurInfo permet de connaître le détail de l'erreur.
<Image> : Nom de champ ou variable de type WDPic
Image à sauver. Cette image peut correspondre :
  • WINDEV au nom du champ Editeur d'images à manipuler.
  • Versions 25 et supérieures
    au nom d'une variable de type WDPic à manipuler.
    Nouveauté 25
    au nom d'une variable de type WDPic à manipuler.
    au nom d'une variable de type WDPic à manipuler.
<Fichier> : Chaîne de caractères optionnelle (avec guillemets)
Nom et chemin du fichier image à sauver. L’extension du fichier détermine le type de l’image à sauver.
Si ce paramètre n'est pas précisé :
  • WINDEV Dans le cas d'un champ Editeur d'images : l’action effectuée correspond à la fonctionnalité d'enregistrement de l’éditeur d’images (clic sur la disquette dans le ruban).
    Si l'image n'a jamais été enregistrée, le sélecteur de fichier s'affiche.
  • Versions 25 et supérieures
    Dans le cas d'une variable de type WDPic, une erreur fatale est affichée.
    Nouveauté 25
    Dans le cas d'une variable de type WDPic, une erreur fatale est affichée.
    Dans le cas d'une variable de type WDPic, une erreur fatale est affichée.
Classification Métier / UI : Code IHM
Composante : wd250pic.dll
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire