PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Importer les styles d'un document
Importer les styles d'un document
Cet exemple permet de lister les styles d'un document pour ajouter le style voulu dans un autre document.
// Lister les styles d'un document
MonChampDoc est un Champ
// Récupération d'un document associé
MonDoc est un Document = MonChampDoc
// Listage de tous les styles utilisés par le document
POUR TOUT UnStyleDuDoc DE MonDoc.Style
Trace(UnStyleDuDoc.StyleID)
FIN
 
// Ajouter le style "Titre1" dans un document et l'appliquer à la sélection
// La définition du style "Titre1" provient d'un autre document
MonChampDoc est un Champ = {"MonChampTT", indChamp}
// Récupération d'un document associé
MonDoc est un Document = MonChampDoc
// Si le style "Titre1" n'existe pas,
// on va l'ajouter à partir d'un document contenant des styles prédéfinis
SI MonDoc.Style["Titre1"] = Null ALORS
// Ouvre un document contenant les styles
MonDocContenantLesStyles est un Document = "c:\MonDocAvecMesStyles.docx"
// Récupère le style Titre 1
StyleTitre1 est un docStyle <- MonDocContenantLesStyles.Style["Titre1"]
SI StyleTitre1 <> Null ALORS
// Ajoute le style dans le document
Ajoute(MonDoc.Style, StyleTitre1)
FIN
FIN
// On applique le style à la sélection
StyleTitre1PourSelection est un docStyle <- MonDoc.Style["Titre1"]
SI StyleTitre1PourSelection <> Null ALORS
// Créer le fragment (à partir de la sélection)
f est docFragment(MonChampDoc.Valeur, MonChampDoc.Curseur, ...
MonChampDoc.LongueurSélection)
// Applique le style Titre1 à la sélection
f.StyleID = StyleTitre1PourSelection.Identifiant
FIN
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire