PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Conditions d'utilisation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
ActionDéclareUndo (Fonction)
En anglais : ActionDeclareUndo
Déclare comment annuler une action ajoutée avec la fonction ActionDo. Cette fonction DOIT être appelée durant l'exécution de la procédure fournie à la fonction ActionDo.
Exemple
ActionDo(FEN_MonEditeur, ProcCréeLib, "Nouveau")
PROCÉDURE INTERNE ProcCréeLib(sLib)
pNouveau est un Champ
pNouveau <- ChampCrée("LIB_" + DonneIdentifiant(), typTexte, 150, 150, 80, 20)
pNouveau..Libellé = sLib
ActionDéclareUndo(ProcAnnuler)
PROCÉDURE INTERNE ProcAnnuler()
ChampSupprime(pNouveau)
FIN
FIN
ActionDéclareUndo(AnnulerOperation, CLIENT.IDClient)
 
// Gestion du Undo
PROCÉDURE INTERNE AnnulerOperation(nIDClient)
 
SI HLitRecherchePremier(CLIENT, IDClient, nIDClient) ALORS
  SourceVersEcran()
FIN
 
FIN
Syntaxe
ActionDéclareUndo(<Procédure WLangage> [, <Paramètre 1> [... [, <Paramètre N>]]])
<Procédure WLangage> : Nom de procédure
Nom d'une procédure WLangage à exécuter. Le code de cette procédure doit permettre d'annuler l'action créée avec la fonction ActionDo.
Cette procédure est appelée lors de l'utilisation du raccourci Ctrl + Z ou lors de l'appel de la fonction ActionUndo.
Remarque : L'utilisation d'une procédure interne permet un accès direct aux variables locales.
<Paramètre 1> : Type quelconque optionnel
Premier paramètre optionnel à passer à la procédure.
Ces paramètres correspondent généralement à des valeurs permettant de rétablir l'état précédent.
<Paramètre N> : Type quelconque optionnel
Nème paramètre optionnel à passer à la procédure.
Ces paramètres correspondent généralement à des valeurs permettant de rétablir l'état précédent.
Remarques

Conditions d'utilisation

Si cette fonction est appelée en dehors d'une procédure WLangage ajoutée avec la fonction ActionDo, une erreur WLangage est affichée.
Composante : wd250obj.dll
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire