PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Champ Vidéo : Initialisation
VidéoChangeDriver (Exemple)
Champ Vidéo : Initialisation
Cet exemple permet d'initialiser un champ Vidéo en fonction des drivers du poste.
tabDriversCamera  est un tableau de chaîne
nIndice est un entier
 
// Récupération du nom du driver de caméra précédemment utilisé
sDriverEnCours est une chaîne = ChargeParamètre(CAM_WEBCAM..NomComplet, CAM_WEBCAM..Driver)
 
// Liste des drivers de caméra disponibles au format :
// Nom du driver 1> + TAB + <Version du driver 1> + RC + ...
sListeDriverVideo est une chaîne = VidéoListeDriver(viDirectShow)
// ou CaméraListeDriver(viDirectShow)
// La liste des drivers est stockée dans une variable tableau
ChaîneVersTableau(sListeDriverVideo, tabDriversCamera, RC, TAB)
// Il y en a au moins un drivers de caméra ou WebCam ?
SELON tabDriversCamera.Occurrence
CAS 0
// Aucun
ToastAffiche("Aucun drivers de caméra n'a été trouvé sur le poste, " +
"le champ a été désactivé", toastCourt, cvMilieu,chCentre, RougeClair)
CAM_WEBCAM.Etat = Grisé
CAS 1
// un seul driver : on le prend
nIndice = 1
 
AUTRE CAS
// plusieurs drivers
// on cherche si le driver précédemment mémorisé est présent dans la liste
nIndice = TableauCherche(tabDriversCamera, tcLinéaire, sDriverEnCours)
SI nIndice < 1 ALORS
// Pas trouvé : on prend le premier de la liste
nIndice=1
FIN
FIN
 
// Un driver de sélectionné autre que celui du champ ?
SI nIndice>0 _ET_ PAS CAM_WEBCAM..Driver = tabDriversCamera[nIndice] _ET_ ...
// On change le driver utilisé (et on vérifie que le changement fonctionne)
PAS VidéoChangeDriver(CAM_WEBCAM, tabDriversCamera[nIndice]) ALORS
//ou PAS CaméraChangeDriver(CAM_WEBCAM, tabDriversCamera[nIndice])
ToastAffiche("Impossible d'utiliser le drivers de caméra " +
tabDriversCamera[nIndice] + ", le champ a été désactivé" + RC +
ErreurInfo(),toastCourt, cvMilieu, chCentre, RougeClair)
CAM_WEBCAM.Etat = Grisé
FIN
 
// On mémorise le driver
// Il faut sauver ce même paramètre si une option de la fenêtre permet de changer de caméra
// afin que ce driver de caméra soit pris en compte par défaut
SauveParamètre(CAM_WEBCAM.NomComplet, CAM_WEBCAM.Driver)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire