DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple d'affichage de la position sur une carte avec un marqueur
CarteAffichePosition (Exemple)
Exemple d'affichage de la position sur une carte avec un marqueur
WINDEV Cet exemple permet d'afficher une adresse sur un champ Carte, avec un zoom défini au niveau de la rue. Un marqueur est ajouté à la position spécifiée par l'adresse.
adrClient est un Adresse
// Adresse à afficher
adrClient.Rue = "3 Rue de Puech Villa"
adrClient.CodePostal = "34090"
adrClient.Ville = "Montpellier"
adrClient.Pays = "FRANCE"
 
// Zoom au niveau de la rue
CARTE_Client.Zoom = 16
 
// En fonction de la plateforme
<COMPILE SI TypeConfiguration=ApplicationWindows>
// Coordonnées de l'adresse
Coord est un gglCoordonnées = GglAdresseVersCoordonnées(adrClient.Rue + ", "+
adrClient.CodePostal + " " + adrClient.Ville + " " + adrClient.Pays)
// Récupère la latitude et longitude et met l'adresse à jour
adrClient.Position.Latitude = Coord.Latitude
adrClient.Position.Longitude = Coord.Longitude
<FIN>
<COMPILE SI TypeConfiguration=Android OU TypeConfiguration=iOS>
// Met à jour l'adresse avec la Latitude et la Longitude
adrClient = géoRécupèreAdresse(adrClient.Rue + ", " + adrClient.CodePostal +
" " + adrClient.Ville + " " + adrClient.Pays)
<FIN>
 
// L'adresse a-t-elle une latitude et une longitude ?
SI adrClient <> Null _ET_ adrClient.Position.Latitude <> 0 _ET_
adrClient.Position.Longitude <> 0 ALORS
MarqueurAdresse est un Marqueur
MarqueurAdresse.Position = adrClient.Position
MarqueurAdresse.Nom = "Adresse client"
MarqueurAdresse.Image = "maison.gif"
MarqueurAdresse.ActionClic = ClicSurAdresse
 
// Ajoute un marqueur sur la position
CarteAjouteMarqueur(CARTE_Client, MarqueurAdresse)
// Centre la carte sur la position
SI PAS CarteAffichePosition(CARTE_Client, adrClient.Position) ALORS
Erreur("Impossible d'afficher cette position", ErreurInfo())
FIN
SINON
// Centre la carte sur l'adresse, mais sans marqueur
// car la position n'a pas pu être déterminée
SI PAS CarteAffichePosition(CARTE_Client, adrClient) ALORS
Erreur("Impossible d'afficher cette adresse", ErreurInfo())
SINON
Info("Position approximative")
FIN
FIN
 
PROCÉDURE INTERNE ClicSurAdresse(MarqueurCarte est un Marqueur)
ToastAffiche(ChaîneConstruit("%1, position : %2 N, %3 E ",
MarqueurCarte.Nom, MarqueurCarte.Position.Latitude,
MarqueurCarte.Position.Longitude))
FIN
Version minimum requise
  • Version 17
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire