PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Modifie ou renvoie l'état de visibilité de la fenêtre interne de patience lors de l'ajout d'éléments supplémentaires dans un champ Table infinie.
Exemple
// Evénement "Ajout d'éléments supplémentaires"
TableAjoutEnCours(TABLE_TableInfinie, Vrai)
ThreadExécute("ThreadRemplissage", threadNormal, maProcRecupResultatSuppl)
 
PROCÉDURE INTERNE maProcRecupResultatSuppl()
REQ_PlusDeDonnées.IDMin = TABLE_TableInfinie[TABLE_TableInfinie..Occurrence].ID
HExécuteRequête(REQ_PlusDeDonnées)
HLitPremier(REQ_PlusDeDonnées)
tabLignes est un tableau de chaînes
TANTQUE PAS HEnDehors(REQ_PlusDeDonnées)
Ajoute(tabLignes, REQ_PlusDeDonnées.Titre + TAB + REQ_PlusDeDonnées.IDArticle)
HLitSuivant(REQ_PlusDeDonnées)
FIN
ExécuteThreadPrincipal(ProcAjoutDansTable)
PROCÉDURE INTERNE ProcAjoutDansTable()
POUR TOUTE sLigne DE tabLignes
TableAjoute(TABLE_TableInfinie, sLigne)
FIN
TableAjoutEnCours(TABLE_TableInfinie, Faux)
FIN
FIN
Syntaxe

Modifier l'état de visibilité de la fenêtre interne de patience Masquer les détails

TableAjoutEnCours(<Champ Table> , <Visible>)
<Champ Table> : Nom de champ
Nom du champ Table à manipuler.
<Visible> : Booléen
  • Vrai pour afficher la fenêtre interne de patience,
  • Faux pour la masquer.

Récupérer l'état de visibilité de la fenêtre interne de patience Masquer les détails

<Résultat> = TableAjoutEnCours(<Champ Table>)
<Résultat> : Booléen
  • Vrai si la fenêtre interne de patience est affichée,
  • Faux dans le cas contraire.
<Champ Table> : Nom de champ
Nom du champ Table à manipuler.
Remarques
  • Lors de l'utilisation d'un champ Table infinie, une fenêtre interne de patience (contenant un champ Jauge) est affichée au-dessus des lignes du champ Table pendant l'ajout des données supplémentaires dans le champ. Cette fenêtre de patience est masquée à la fin de l'exécution de l'événement "Ajout d'éléments supplémentaires".
  • La fonction TableAjoutEnCours permet par exemple de contrôler l'affichage de la fenêtre de patience lorsque l'actualisation des données du champ Table est effectuée dans un thread secondaire. Il est ainsi possible d'éviter de figer l'application (l'exemple utilise cette méthode).
  • Lorsque la fenêtre de patience est rendue visible par la fonction TableAjoutEnCours, l'événement "Ajout d'éléments supplémentaires" du champ Table n'est pas exécuté.
  • Pour masquer le bandeau de rafraîchissement, il est nécessaire d'appeler le code :
    TableAjoutEncours(<Champ Table>, Faux)
    autant de fois que le code
    TableAjoutEncours(<Champ Table>, Vrai)
    a été exécuté.
Composante : wd240obj.dll
Version minimum requise
  • Version 21
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire