DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Renvoie la date du premier jour de l'année.
Exemple
// Affiche les clients créés depuis le début de l'année
HLitPremier(Client, Nom)
TANTQUE HEnDehors() = Faux
// Traitement de l'enregistrement
SI (Client.DateCreation >= PremierJourDeLAnnée()) ALORS
Trace(Client.Nom)
FIN
HLitSuivant(Client, Nom)
FIN
Syntaxe

Obtenir le premier jour de l'année à partir d'une date Masquer les détails

<Résultat> = PremierJourDeLAnnée([<Date>])
<Résultat> : Chaîne de caractères ou variable de type Date
Premier jour de l'année (au format AAAAMMJJ) pour la date spécifiée.
<Date> : Chaîne de caractères, variable de type Date ou variable de type DateHeure optionnelle
Date pour laquelle le premier jour de l'année doit être calculé. Cette date peut correspondre à :
  • une chaîne de caractères au format AAAAMMJJ (AAAA correspond à l'année, MM au mois et JJ au jour).
  • une chaîne de caractères au format AAAAMMJJHHmmSSCC (AAAA correspond à l'année, MM au mois, JJ au jour, HH aux heures, mm aux minutes, SS aux secondes et CC aux centièmes de seconde (utiliser CCC pour les millièmes de seconde)). Dans ce cas, seule la date est prise en compte.
  • une variable de type Date.
  • une variable de type DateHeure. Dans ce cas, seule la date est prise en compte.
Si ce paramètre n'est pas spécifié, la date du jour est utilisée par défaut.

Obtenir le premier jour de l'année à partir d'une année Masquer les détails

<Résultat> = PremierJourDeLAnnée(<Année>)
<Résultat> : Chaîne de caractères ou variable de type Date
Premier jour de l'année (au format AAAAMMJJ).
<Année> : Entier
Année pour laquelle le premier jour est recherché.
Remarques
Cette fonction permet de calculer simplement des fourchettes de dates.
Liste des exemples associés :
Gestion des dates Exemples unitaires (WINDEV) : Gestion des dates
[ + ] Utilisation du type Date du WLangage et des fonctions de manipulations de dates.
Classification Métier / UI : Code neutre
Composante : wd280std.dll
Version minimum requise
  • Version 21
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire