PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Modifie le libellé d'une catégorie sur l'axe des abscisses d'un graphe de type Heatmap.
Note : Par défaut, le libellé d'une catégorie correspond à la valeur numérique de la catégorie.
Exemple
grHMLibelléX(GRF_HMap, 1, "X1")
grHMLibelléX(GRF_HMap, 2, "X2")
// Libellé des axes
POUR TOUT ÉLÉMENT nIndice, nTempérature DE gtaTempérature
grHMLibelléX(GRF_Graphe, nIndice, "" + nTempérature)
FIN
POUR TOUT ÉLÉMENT nIndice, nVent DE gtaVent
grHMLibelléY(GRF_Graphe, nIndice, "" + nVent)
FIN
Syntaxe
grHMLibelléX(<Nom du graphe> , <X> , <Libellé>)
<Nom du graphe> : Nom de champ ou chaîne de caractères
Nom du graphe à manipuler. Ce nom correspond :
  • soit au nom du graphe défini par programmation avec la fonction grCrée.
  • soit au nom du champ Graphe présent dans l'éditeur de fenêtres ou d'états.
PHP Seuls les champs Graphe interactif sont disponibles.
<X> : Entier
Position de la catégorie sur l'axe des abscisses.
<Libellé> : Chaîne de caractères
Nouveau libellé de la catégorie. Si ce paramètre correspond à une chaîne vide (""), la valeur numérique de la catégorie est affichée.
Remarques
Le libellé défini avec la fonction grHMLibelléX sera pris en compte lors du prochain appel à la fonction grDessine.
Liste des exemples associés :
WD Graphe Exemples didactiques (WINDEV) : WD Graphe
[ + ] Cet exemple didactique présente diverses utilisations du champ graphe.
Différents types de graphe sont présentés :
- Secteur (ou camembert)
- Secteur multiniveau (ou sunburst)
- Courbe
- Nuage de points
- Histogramme
- Aire
- ...

Les fonctionnalités mises en avant sont la personnalisation des graphes par programmation ainsi que le remplissage du graphe à partir d'un fichier de données HFSQL ou dans l'éditeur.
Composante : wd280grf.dll
Version minimum requise
  • Version 21
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire