PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Photos enregistrées
  • Répertoires de sauvegarde
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Lance l'application caméra native de l'appareil afin de prendre une photo.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
sPhoto est une chaîne = PhotoLanceAppli()
SI sPhoto <> "" ALORS
Info("Photo sauvegardée dans le fichier : " + sPhoto)
FIN
Versions 21 et supérieures
// Lance l'application
PhotoLanceAppli(CB_PhotoLanceAppli)

PROCEDURE INTERNE CB_PhotoLanceAppli(sChemin est une chaîne)
// Si le retour vaut chaîne vide (""), une erreur a eu lieu
SI sChemin ~= "" ALORS
Erreur(ErreurInfo())
RETOUR
FIN
// Message de fin d'enregistrement
Info("La photo a été enregistrée ici : " + sChemin)
Nouveauté 21
// Lance l'application
PhotoLanceAppli(CB_PhotoLanceAppli)

PROCEDURE INTERNE CB_PhotoLanceAppli(sChemin est une chaîne)
// Si le retour vaut chaîne vide (""), une erreur a eu lieu
SI sChemin ~= "" ALORS
Erreur(ErreurInfo())
RETOUR
FIN
// Message de fin d'enregistrement
Info("La photo a été enregistrée ici : " + sChemin)
// Lance l'application
PhotoLanceAppli(CB_PhotoLanceAppli)

PROCEDURE INTERNE CB_PhotoLanceAppli(sChemin est une chaîne)
// Si le retour vaut chaîne vide (""), une erreur a eu lieu
SI sChemin ~= "" ALORS
Erreur(ErreurInfo())
RETOUR
FIN
// Message de fin d'enregistrement
Info("La photo a été enregistrée ici : " + sChemin)
Syntaxe

Lancer l'application caméra native (appel bloquant) Masquer les détails

<Résultat> = PhotoLanceAppli()
<Résultat> : Chaîne de caractères
  • Chemin complet du fichier dans lequel la photo a été enregistrée,
  • Chaîne vide ("") en cas d'erreur. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
Versions 21 et supérieures

Lancer l'application caméra native (appel non bloquant) Masquer les détails

<Résultat> = PhotoLanceAppli([<Nom de la procédure>])
<Résultat> : Chaîne de caractères
  • Chemin complet du fichier dans lequel la photo a été enregistrée,
  • Chaîne vide ("") en cas d'erreur. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Nom de la procédure> : Chaîne de caractères (avec ou sans guillemets)
Nom de la procédure WLangage (également nommée "callback") appelée lors de l'enregistrement de la photo.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure> (<Chemin>)

où <Chemin> correspond au chemin de sauvegarde de l'image.
Nouveauté 21

Lancer l'application caméra native (appel non bloquant) Masquer les détails

<Résultat> = PhotoLanceAppli([<Nom de la procédure>])
<Résultat> : Chaîne de caractères
  • Chemin complet du fichier dans lequel la photo a été enregistrée,
  • Chaîne vide ("") en cas d'erreur. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Nom de la procédure> : Chaîne de caractères (avec ou sans guillemets)
Nom de la procédure WLangage (également nommée "callback") appelée lors de l'enregistrement de la photo.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure> (<Chemin>)

où <Chemin> correspond au chemin de sauvegarde de l'image.

Lancer l'application caméra native (appel non bloquant) Masquer les détails

<Résultat> = PhotoLanceAppli([<Nom de la procédure>])
<Résultat> : Chaîne de caractères
  • Chemin complet du fichier dans lequel la photo a été enregistrée,
  • Chaîne vide ("") en cas d'erreur. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Nom de la procédure> : Chaîne de caractères (avec ou sans guillemets)
Nom de la procédure WLangage (également nommée "callback") appelée lors de l'enregistrement de la photo.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure> (<Chemin>)

où <Chemin> correspond au chemin de sauvegarde de l'image.
Remarques

Photos enregistrées

Les paramètres des photos enregistrées (format, résolution, taille) sont ceux définis dans le paramétrage de l'application native de prise de photos.

Répertoires de sauvegarde

AndroidWidget Android Dans les applications Android, la photo est stockée sur la SDCard de l'appareil et est également automatiquement ajoutée à l'album.
Si des photos doivent être utilisées dans vos applications Android, il est conseillé de travailler avec des miniatures et non les photos originales prises par l'appareil. Pour générer les miniatures, utilisez la fonction VidéoGénèreMiniature.
iPhone/iPad Dans les applications iPhone/iPad :
Par défaut, les photos sont enregistrées dans le répertoire "Documents" de l'application.
Il est possible également de :
  • mémoriser le contenu binaire de l'image dans une base de données, grâce à une rubrique de type Mémo.
  • ajouter la photo dans l'album photo de l'appareil grâce à la fonction AlbumSauve. Dans ce cas, l'image pourra être réutilisée grâce à la fonction AlbumSélecteur.
Composante : wd240android.jar
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire