PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Recherche dans les emails d'une session Outlook
EmailCherchePremier (Exemple)
Recherche dans les emails d'une session Outlook
Cet exemple permet d'effectuer une recherche des emails contenant la chaîne "PC Soft" dans le sujet ou dans le corps du message. Seuls les emails reçus sont pris en compte
// Ouverture d'une session Outlook
IDSession est un entier
IDSession = EmailOuvreSessionOutlook("")
...
SI EmailCherchePremier(IDSession, emailSujet + emailCorps, ...
"PC Soft") = Vrai ALORS
// Enumération des emails trouvés
TANTQUE Email.EnDehors = Faux
// Affiche l'expéditeur et le sujet dans un champ Table
TableAjoute(TABLE_EmailTrouve, Email.Expéditeur + ...
TAB + Email.Sujet)
// Email trouvé suivant
EmailLitSuivant(IDSession)
FIN
SINON
Info("Aucun email n'a été trouvé")
FIN
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire