PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Détruit tous les emails marqués comme supprimés (état "Deleted") du dossier courant d’une session IMAP.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Versions 22 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 22
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
Exemple
cMaSession est une emailSessionIMAP
...
SI EmailOuvreSession(cMaSession) ALORS
cMonEmail est un Email
EmailLitPremier(cMaSession, cMonEmail)
TANTQUE PAS cMonEmail..EnDehors
EmailSupprimeMessage(cMaSession, cMonEmail)
EmailLitSuivant(cMaSession, cMonEmail)
FIN
// Détruit les emails supprimés
EmailDétruit(cMaSession)
EmailFermeSession(cMaSession)
FIN
 
Syntaxe
<Résultat> = EmailDétruit(<Session>)
<Résultat> : Booléen
  • Vrai si la destruction a été effectuée,
  • Faux dans le cas contraire.
<Session> : Variable de type emailSessionIMAP
Nom de la variable de type emailSessionIMAP correspondant à la session sur laquelle les messages doivent être détruits.
Composante : wd240com.dll
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire