PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
xlsCoordonnéesVersNom (Fonction)
En anglais : xlsCoordinatesToName
Récupère le nom d'une cellule d'une feuille XLS ou d'un champ Tableur en fonction de ses coordonnées.
Exemple
NomCellule est une chaîne = xlsCoordonnéesVersNom(1,1)
Syntaxe
<Résultat> = xlsCoordonnéesVersNom(<Colonne> , <Ligne>)
<Résultat> : Chaîne de caractères
Nom de la cellule. Ce nom est du type "A1".
<Colonne> : Entier
Numéro de la colonne identifiant la cellule.
<Ligne> : Entier
Numéro de la ligne identifiant la cellule.
Composante : wd270xls.dll
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Pour ceux qui travaillent en WEBDEV
Traduction d'un numéro de colonne en lettre
PROCÉDURE f_col_let(icol)
ncal est un numérique
nent est un entier
nreste est entier
sret est une chaîne
SI icol <= 26 ALORS
sret = Caract(icol + 64)

SINON
nreste = modulo(icol,26)
ncal = icol / 26
nent = PartieEntière(ncal)
SI nreste = 0 ALORS
nreste = 26
nent = nent - 1
FIN
sret = f_col_let(nent) + Caract(nreste + 64)
FIN
RENVOYER(sret)
Franck TOUZEL
01 mar. 2022