PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Envoie une requête REST et attend la réponse du serveur.
Exemple
cMaRequete est un restRequête
cMaRequete..URL = "<adresse serveur>"
cMaReponse est un restRéponse = RESTEnvoie(cMaRequete)
SI ErreurDétectée ALORS
Erreur(ErreurInfo(errComplet))
SINON
Info(cMaReponse..Contenu)
FIN
// L'exemple de code ci-dessous montre comment appeler un Webservice REST WINDEV avec paramètres.
// La procédure dans le Webservice est de cette forme :
// PROCEDURE PRIVÉE UpdateBandeauhaut(bModeTest est un booléen)

// L'URL de test est alors de la forme suivante :
// http://<IP du serveur>/<composante commune>
// ?test#/<composante commune>/UpdateBandeauhaut/{bModeTest}|GET

// Code WLangage permettant de l'appeler en passant le paramètre
cMaRequete est un restRequête
cMaRequete..Méthode = httpGet
cMaRequete..URL = "http://<IP du serveur>/CDM/UpdateBandeauhaut/1"
//Où CDM est la composante commune et 1 la valeur du paramètre

cMaReponse est un restRéponse = RESTEnvoie(cMaRequete)
SI ErreurDétectée ALORS
Erreur(ErreurInfo(errComplet))
SINON
SI cMaReponse..Contenu = Vrai ALORS
Info("Le site a bien été mis à jour.")
SINON
Erreur(cMaReponse..Contenu)
FIN
FIN
Syntaxe

Syntaxe utilisant une variable de type restRequête Masquer les détails

<Réponse REST> = RESTEnvoie(<Requête REST>)
<Réponse REST> : Variable de type restRéponse
Nom de la variable de type restRéponse contenant la réponse reçue du serveur REST.
<Requête REST> : Variable de type restRequête
Nom de la variable de type restRequête contenant les caractéristiques de la requête REST à envoyer au serveur.

Syntaxe simplifiée d'envoi d'une requête Masquer les détails

<Réponse REST> = RESTEnvoie(<URL>)
<Réponse REST> : Variable de type restRéponse
Nom de la variable de type restRéponse contenant la réponse reçue du serveur REST.
<URL> : Chaîne de caractères (avec guillemets)
URL à interroger.
Remarques
Composante : wd260com.dll
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire