PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Cryptage/décryptage
DécrypteStandard (Exemple)
Cryptage/décryptage
Exemple de cryptage/décryptage.
bufCléDeCryptage est un Buffer
// avec crypteAES128, la clé est sur 128 bits
// - Soit on prend le hash sur 128 bits d'une clé 'quelconque'
// (à faire côté cryptage et décryptage)
bufCléDeCryptage = HashChaîne(HA_MD5_128, "clé de cryptage")
// - Soit on donne une clé de exactement la  bonne taille 128 bits soit 16 octets
// bufCléDeCryptage = "clécrypta128bits"
// Et donc côté cryptage, un exemple de code peut être :  
// bufNonCrypté est un buffer = "données secrètes"
// bufDonnéesCryptées = CrypteStandard(bufNonCrypté, bufCléDeCryptage, ...
//                 crypteAES128, crypteCBC, cryptePaddingPKCS)
 
// Décryptage
QUAND EXCEPTION DANS
bufRésultat est un Buffer = DécrypteStandard(bufDonnéesCryptées, bufCléDeCryptage, ...
crypteAES128, crypteCBC, cryptePaddingPKCS)
FAIRE
// Echec du décryptage car les valeurs ne sont pas bonnes :
// taille de clé incorrect, taille de message insuffisante pour le vecteur initial...
ErreurDéclenche(1, ExceptionInfo())
FIN
 
SI ErreurDétectée ALORS
// Problème de décryptage
Erreur("Echec du décryptage ", ErreurInfo())
SINON
// Décryptage OK, bufRésultat contient le buffer décrypté
Info("Données décryptées : ", bufRésultat)
FIN
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire