PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie une variable de type Image contenant une page d’un fichier PDF.
Versions 25 et supérieures
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 25
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Android Cette fonction est désormais disponible pour les applications Android.
Versions 26 et supérieures
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Nouveauté 26
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Exemple
// Extrait la page 3 du fichier texte.pdf
MonImage est Image = PDFExtraitPage("texte.pdf", 3)
SAI_NumPagePDF.CouleurFond = Blanc
SI SAI_NumPagePDF = 0 ALORS
Info("Vous devez indiquer le numéro de page à extraire")
SAI_NumPagePDF.CouleurFond = RougePastel
RepriseSaisie(SAI_NumPagePDF)
RETOUR
FIN
 
sNouveauChemin est une chaîne = fRepSélecteur(sCheminOrigine, ...
"Sélecteur de répertoire","Sélectionnez le répertoire d’extraction de la page")
 
// Recherche dans le fichier DOC_Contact du libellé contenu dans la table.
HLitRecherche(DOC_Contact, IDDOC_Contact, TABLE_Fen_Liste_Documents.COL_IDDOC_Contact)
SI HTrouve() ALORS
Sablier()
 
MonCheminPDF est une chaîne = sNouveauChemin + "\" + ...
DOC_Contact.IDDOC_Contact + "." + DOC_Contact.Format
 
// Document est un mémo contenant le PDF
SI PAS HExtraitMémo(DOC_Contact, Document, MonCheminPDF) ALORS
Erreur(HErreurInfo())
SINON
SI PDFNombreDePages(MonCheminPDF) < SAI_NumPagePDF ALORS
Erreur("Le PDF ne contient pas suffisamment de pages", ...
"Traitement annulé")
RETOUR
FIN
 
MonImagePDF est une Image = PDFExtraitPage(MonCheminPDF, ...
SAI_NumPagePDF)
// Suppression du PDF d'origine
fSupprime(MonCheminPDF)
 
MonImagePNG est une chaîne = sNouveauChemin + "\" + DOC_Contact.IDDOC_Contact + ...
 "_Page" + SAI_NumPagePDF + ".PNG"
dSauveImagePNG(MonImagePDF, MonImagePNG)
LanceAppliAssociée(MonImagePNG)
FIN
Sablier(Faux)
FIN
Syntaxe
<Résultat> = PDFExtraitPage(<Chemin du fichier> , <Numéro de la page> [, <Largeur> [, <Hauteur> [, <Mot de passe>]]])
<Résultat> : Image (variable de type image)
Variable de type Image contenant l'image de la page extraite. L’image renvoyée est une image raster (non vectorielle).
Remarque : Si le fichier PDF n’existe pas ou si la page n’existe pas, la variable Image renvoyée sera invalide. La variable ErreurDétectée correspondra à Vrai.
<Chemin du fichier> : Chaîne de caractères (avec guillemets)
Chemin du fichier PDF à partir duquel la page doit être extraite.
<Numéro de la page> : Entier
Numéro de la page à extraire.
<Largeur> : Entier optionnel
Largeur à laquelle la page doit être rastérisée.
Si ce paramètre n'est pas spécifié (ou si ce paramètre vaut 0), la hauteur et la largeur seront calculées à partir de la taille en millimètres de la page, en considérant un DPI de 300.
<Hauteur> : Entier optionnel
Hauteur à laquelle la page doit être rastérisée.
Si ce paramètre n'est pas spécifié (ou si ce paramètre vaut 0), la hauteur et la largeur seront calculées à partir de la taille en millimètres de la page, en considérant un DPI de 300.
<Mot de passe> : Chaîne de caractères optionnelle (entre guillemets)
Mot de passe du document PDF.
Classification Métier / UI : Code métier
Composante : wd260pdf.dll
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire