PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Récupère les indicateurs définis sur un email d'une session IMAP.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Versions 22 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 22
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Android Cette fonction est désormais disponible pour les applications Android.
Exemple
cMaSession est une emailSessionIMAP
...
tabIndicateur est un tableau de chaînes
cMonEmail est un Email
...
SI EmailOuvreSession(cMaSession) ALORS
SI EmailLitPremier(cMaSession, cMonEmail) ALORS
tabIndicateur = EmailRécupèreIndicateur(cMaSession, cMonEmail)
POUR TOUT sIndicateur DE tabIndicateur
Trace(sIndicateur)
FIN
FIN
FIN
 
Syntaxe
<Résultat> = EmailRécupèreIndicateur(<Session IMAP> , <Email>)
<Résultat> : Tableau de chaîne de caractères
Tableau contenant l'ensemble des indicateurs définis sur le message. Ces indicateurs correspondent :
  • à la liste des indicateurs définis par la RFC (\Seen, \Answered, \Flagged, \Deleted, \Draft et \Recent),
  • aux indicateurs définis par le client.
<Session IMAP> : Variable de type emailSessionIMAP
Nom de la variable de type emailSessionIMAP correspondant à la session IMAP associée à l'email.
<Email> : Variable de type Email
Nom de la variable de type Email correspondant à l'email à manipuler.
Composante : wd250com.dll
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire