PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Principe
  • Comment le faire ?
  • Envoi direct de commandes
  • Dialogue avec un serveur SSH
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Principe
Secure Shell (SSH) est un protocole de communication sécurisé. Les données échangées sont sécurisées à l'aide de clés de chiffrement.
Un serveur peut supporter le protocole sécurisé SSH pour recevoir des commandes à distance.
WINDEV et WEBDEV proposent des fonctions permettant de se connecter, d'ouvrir une session, de transmettre des commandes à exécuter et de récupérer le résultat de ces commandes.
Le protocole géré est SSH-2.
Il existe deux méthodes pour communiquer avec un serveur SSH :
Comment le faire ?

Envoi direct de commandes

L'envoi directe de commandes se fait à l'aide de la fonction SSHCommande. Les paramètres de connexion au serveur SSH doivent être décrits dans une variable de type sshSession.
Exemple :
cMaSession est une sshSession
buffSortie est un Buffer
cMaSession.Adresse = "127.0.0.1"
cMaSession.Port = 22
cMaSession.Utilisateur = "login"
cMaSession.MotDePasseUtilisateur = "pass"
nExitCode est un entier
sSortie est une chaîne ANSI
sSortieErr est une chaîne ANSI
(nExitCode, sSortie, sSortieErr) = SSHCommande(cMaSession, SAI_Commande)
SI ErreurDétectée ALORS
Erreur(ErreurInfo(errComplet))
RETOUR
FIN
SAI_ExitCode = nExitCode
SAI_StdOut = UTF8VersChaîne(sSortie)
SAI_StdErr = UTF8VersChaîne(sSortieErr)

Dialogue avec un serveur SSH

Le dialogue avec le serveur SSH se fait à l'aide des fonctions suivantes :
SSHConnecteShellOuvre une nouvelle session SSH de type "Shell".
SSHDéconnecteShellFerme une session SSH précédemment ouverte grâce à la fonction SSHConnecteShell.
SSHEcritEcrit des données dans la session SSH spécifiée.
SSHLitLit les données présentes sur le buffer de sortie de la session SSH.
Les paramètres de connexion au serveur SSH doivent être décrits dans une variable de type sshSession.
Exemple :
cMaSession est une sshSession
cMaSession.Adresse = "127.0.0.1"
cMaSession.Port = 22
cMaSession.Utilisateur = "login"
cMaSession.MotDePasseUtilisateur = "pass"
SI SSHConnecteShell(cMaSession) ALORS
Info("Session Ouverte")
bufSortie est un Buffer = "data"
SSHEcrit(cMaSession, bufSortie)
SSHDéconnecteShell(cMaSession)
FIN
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire