PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Ajoute un utilisateur dans la base de données du groupware utilisateur.
Exemple
// Valeurs du nouvel utilisateur
clUtilisateur est un gpwUtilisateur
clUtilisateur.Email = SAI_Email
clUtilisateur.Login = SAI_Login
clUtilisateur.MotDePasse = SAI_MotPasse
clUtilisateur.Nom = SAI_Nom
clUtilisateur.Prénom = SAI_Prenom
clUtilisateur.Téléphone = SAI_Telephone
 
// Ajout de l'utilisateur
nRes est un entier = gpwAjouteUtilisateur(clUtilisateur)
SELON nRes
CAS gpwOk
Info("ok")
 
CAS gpwActivationParEmail
Info("Activation par email")
 
AUTRE CAS
Info("Impossible d'ajouter l'utilisateur." + RC + ErreurInfo())
RETOUR
FIN
 
// Activation de l'utilisateur
SELON gpwActiveUtilisateur(clUtilisateur..Login)
// Activation par email
CAS gpwActivationParEmail
PopupAffiche(POPUP_ValidationInscription)
// Activation immédiate
CAS gpwActivationImmédiate
// Connecte directement l'utilisateur
gpwConnecteUtilisateur(clUtilisateur.Login, clUtilisateur.MotDePasse)
// Affiche la popup de confirmation
PopupAffiche(POPUP_ConfirmationInscription)
AUTRE CAS
Info("Impossible d'activer l'utilisateur." + RC + HErreurInfo())
FIN
Syntaxe
<Résultat> = gpwAjouteUtilisateur(<Utilisateur>)
<Résultat> : Booléen ou constante de type Entier
AndroidiPhone/iPad Correspond à une constante de type Entier :
gpwActivationParEmailL'utilisateur est activé par email. Un email lui est automatiquement envoyé (les caractéristiques de l'email ont été définies dans la page d'administration).
gpwErreurErreur d'ajout.
gpwOkL'utilisateur est immédiatement activé.
<Utilisateur> : Variable de type gpwUtilisateur
Nom de la variable de type gpwUtilisateur contenant les informations de l'utilisateur à ajouter.
Remarques
Selon le mode de validation des nouveaux utilisateurs paramétré dans la page d'administration, l'utilisateur peut être soit immédiatement validé soit en attente d'une validation par email. La fonction gpwActiveUtilisateur permet d'activer l'utilisateur ajouté.
Classification Métier / UI : Code neutre
Composante : wd280gpu.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire