PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Permet de connaître la position de la cellule sélectionnée et de sélectionner une cellule dans un champ Tableau croisé dynamique.
Exemple
// Récupérer la position courante
tcdPos est un tcdPosition
tcdPos = TCDSelect(TCD_Stats)
SI PAS tcdPos..EnDehors ALORS
Trace(tcdPos.Pays + " " + tcdPos.Ville)
FIN
Versions 21 et supérieures
// Parcours des cellules sélectionnées
tcdPos est un tcdPosition de TCD_MonTCD
 
nbSel est un entier = TCDSelectOccurrence(TCD_MonTCD)
POUR i = 1 À nbSel
tcdPos = TCDSelect(TCD_MonTCD, i)
Trace(tcdPos.COL_Date_Jour + ":" + tcdPos.COL_Produit))
FIN
Nouveauté 21
// Parcours des cellules sélectionnées
tcdPos est un tcdPosition de TCD_MonTCD
 
nbSel est un entier = TCDSelectOccurrence(TCD_MonTCD)
POUR i = 1 À nbSel
tcdPos = TCDSelect(TCD_MonTCD, i)
Trace(tcdPos.COL_Date_Jour + ":" + tcdPos.COL_Produit))
FIN
// Parcours des cellules sélectionnées
tcdPos est un tcdPosition de TCD_MonTCD
 
nbSel est un entier = TCDSelectOccurrence(TCD_MonTCD)
POUR i = 1 À nbSel
tcdPos = TCDSelect(TCD_MonTCD, i)
Trace(tcdPos.COL_Date_Jour + ":" + tcdPos.COL_Produit))
FIN
tcdPos est un tcdPosition
// Sélectionner "France / 2014"
tcdPos.Pays = "FRANCE"
tcdPos.Annee = "2014"
TCDSelect(TCD_Stats, tcdPos)
Syntaxe

Récupérer la position de la cellule sélectionnée dans un champ Tableau croisé dynamique Masquer les détails

<Résultat> = TCDSelect(<Champ Tableau croisé dynamique> [, <Rang>])
<Résultat> : Variable de type tcdPosition
Variable de type tcdPosition contenant la position de la cellule sélectionnée dans le champ. Si aucun élément n'est sélectionné, la propriété ..EnDehors de la variable de type tcdPosition renvoyée vaut Vrai.
<Champ Tableau croisé dynamique> : Nom de champ
Nom du champ Tableau croisé dynamique à manipuler.
<Rang> : Entier optionnel
Versions 21 et supérieures
Rang de la sélection dans le cas d'un champ multisélection. Si ce paramètre n'est pas spécifié, la position de la première cellule sélectionnée est renvoyé.
Nouveauté 21
Rang de la sélection dans le cas d'un champ multisélection. Si ce paramètre n'est pas spécifié, la position de la première cellule sélectionnée est renvoyé.
Rang de la sélection dans le cas d'un champ multisélection. Si ce paramètre n'est pas spécifié, la position de la première cellule sélectionnée est renvoyé.

Sélectionner une position dans un champ Tableau croisé dynamique Masquer les détails

TCDSelect(<Champ Tableau croisé dynamique> , <Position> [, <Valeur>])
<Champ Tableau croisé dynamique> : Nom de champ
Nom du champ Tableau croisé dynamique à manipuler.
<Position> : Variable de type tcdPosition
Nom de la variable de type tcdPosition correspondant à la position à sélectionner. Si la position ne correspond pas à une cellule visible, une erreur WLangage est affichée.
<Valeur> : Chaîne de caractères (avec ou sans guillemets)
Nom de la valeur à sélectionner. Si ce paramètre n'est pas spécifié et si plusieurs valeurs sont présentes dans la même cellule, la première valeur est sélectionnée.
Composante : wd250obj.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire