PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Regroupe plusieurs fichiers en un seul fichier. Les fichiers à manipuler ont été créés lors d'un découpage précédent avec la fonction fDécoupe.
Exemple
// Découpe le fichier Video.avi
fDécoupe("Video.avi", 100*1024*1024, "VideoDécoupée")
SI ErreurDétectée ALORS
// Affiche le message d'erreur
Erreur(ErreurInfo())
RETOUR
FIN
 
// Des fichiers "VideoDécoupée.001", "VideoDécoupée.002" ont été créés
// Suppression du fichier source "Video.avi"
fSupprime("Video.avi")
 
// Utilise les fichiers "VideoDécoupée.001", "VideoDécoupée.002"
// pour recréer le fichier "Video.avi"
fRegroupe("VideoDécoupée", "Video.avi")
SI ErreurDétectée ALORS
// Affiche le message d'erreur
Erreur(ErreurInfo())
RETOUR
FIN
Syntaxe
<Résultat> = fRegroupe(<Nom du fichier> [, <Fichier de sortie> [, <Option> [, <Champ Jauge>]]])
<Résultat> : Entier
  • Nombre de fichiers regroupés,
  • 0 en cas d'erreur. Pour connaître le libellé de l'erreur, utilisez la fonction ErreurInfo avec la constante errMessage.
    Remarque : en cas d'erreur, des fichiers de sortie peuvent être présents sur le disque.
<Nom du fichier> : Chaîne de caractères
Nom complet du fichier à regrouper (sans l'extension ".001").
<Fichier de sortie> : Chaîne de caractères optionnelle
Chemin complet du fichier à créer.
Par défaut, <Fichier de sortie> correspond à <Nom du fichier>.
<Option> : Constante de type Entier optionnelle
Par défaut :
  • les fichiers source sont conservés lors du regroupement.
  • si le fichier de sortie existe déjà, la fonction renvoie une erreur.
Il est possible de spécifier les options de regroupement suivantes :
fSupprimeDestinationSi le fichier destination existe déjà, il sera supprimé puis recréé.
fSupprimeSourceLes fichiers source seront supprimés au fur et à mesure du regroupement.
Attention : Si une erreur survient, les fichiers source seront PERDUS et ne pourront pas être retrouvés.
<Champ Jauge> : Nom de champ optionnel
Nom du champ Jauge permettant de suivre la progression du regroupement des différentes parties du fichier.
Composante : wd280std.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire