PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie toutes les valeurs associées à un entête de ligne ou de colonne d'un champ Tableau croisé dynamique.
Exemple
// Renvoie tous les pays affichés dans le champ Tableau croisé dynamique
tabPos est un tableau de tcdPosition
tabPos = TCDListePositionEntête(TCD_Statistiques, COL_Pays)
POUR TOUT dim DE tabPos
// Affiche le total pour chaque pays si > 10000
SI VAL_CA[dim] > 10000
Trace(dim.Pays + " : " + VAL_CA[dim])
FIN
FIN

// Renvoie toutes les villes affichées dans le champ Tableau croisé dynamique
tabPos = TCDListePositionEntête(TCD_Statistiques, COL_Ville)
POUR TOUT dim DE tabPos
// Trace les villes françaises
SI (dim.Pays ~= "FRANCE") ALORS
Trace(dim.Ville)
FIN
FIN
Syntaxe
<Résultat> = TCDListePositionEntête(<Champ Tableau croisé dynamique> , <Entête>)
<Résultat> : Tableau de tcdPosition
Variable de type Tableau de tcdPosition contenant la liste des éléments correspondant à l'entête spécifié.
<Champ Tableau croisé dynamique> : Nom de champ
Nom du champ Tableau croisé dynamique à manipuler.
<Entête> : Chaîne de caractères (avec ou sans guillemets)
Nom de l'entête de lignes ou de colonnes pour lequel les différents éléments doivent être listés. Cet entête doit être visible et affiché dans le champ.
Remarques
Dans le tableau résultat :
  • Les entêtes des parents sont renseignés.
  • Les entêtes des fils ou des autres axes ont pour valeur "*" (propriété ..Cumul = Vrai).
Une même valeur peut être renvoyée plusieurs fois avec un parent différent. Par exemple, si la liste des modèles de véhicules par pays est récupérée, un même modèle peut être utilisé dans plusieurs pays.
Composante : wd250obj.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire