PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Restaure la configuration d'un champ Tableau de bord. Cette configuration est constituée des éléments suivants :
  • position des fenêtres ou pages internes du champ Tableau de bord.
  • taille des fenêtres ou pages internes du champ Tableau de bord.
  • visibilité des fenêtres ou pages internes du champ Tableau de bord.
Remarque : Pour sauver ou restaurer automatiquement la configuration utilisateur, cochez l'option "Mémoriser la configuration des Widgets" dans l'onglet "Détail" de la fenêtre de description du champ.
Versions 20 et supérieures
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible en WEBDEV Serveur.
WEBDEV - Code Navigateur Cette fonction est désormais disponible en code Navigateur.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 20
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible en WEBDEV Serveur.
WEBDEV - Code Navigateur Cette fonction est désormais disponible en code Navigateur.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible en WEBDEV Serveur.
WEBDEV - Code Navigateur Cette fonction est désormais disponible en code Navigateur.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Versions 22 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Android Cette fonction est désormais disponible pour les applications Android.
Nouveauté 22
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Android Cette fonction est désormais disponible pour les applications Android.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Android Cette fonction est désormais disponible pour les applications Android.
Exemple
WINDEV
// Demande à l'utilisateur la configuration qu'il souhaite charger
sFichier est une chaîne

// Ouvre le sélecteur de fichiers
sFichier = fSélecteur("", "", "Sélectionnez un fichier de configuration...",...
"Configuration de tableau de bord" + TAB + "*.tdbconf", "*.tdbconf")
// Si un fichier est sélectionné
SI sFichier <> "" ALORS
// Récupère la configuration contenue dans le fichier
sConfiguration est chaîne = fChargeTexte(sFichier)
// Charge la configuration
SI TDBChargeConfiguration(TDB_TableauDeBord, sConfiguration) ALORS
ToastAffiche("La configuration a été chargée", toastCourt, cvMilieu, chCentre)
SINON
Erreur("Erreur en chargement de configuration", ErreurInfo())
FIN
FIN
WEBDEV - Code Serveur
// Récupération d'un fichier précédemment sauvé
SI fFichierExiste(fRepWeb() + ["\"] + "ConfigTDB.tdb") ALORS
sMaconfig = fChargeTexte(fRepWeb() + ["\"] + "ConfigTDB.tdb")
TDBChargeConfiguration(TDB_FuseauxHoraires, sMaconfig)
FIN
Versions 22 et supérieures
AndroidiPhone/iPad
// Récupération d'un fichier précédemment sauvé
SI fFichierExiste(fRepEnCours() + ["\"] + "ConfigTDB.tdb") ALORS
sMaConfig = fChargeTexte(fRepEnCours() + ["\"] + "ConfigTDB.tdb")
TDBChargeConfiguration(TDB_FuseauxHoraires, sMaConfig)
FIN
Nouveauté 22
AndroidiPhone/iPad
// Récupération d'un fichier précédemment sauvé
SI fFichierExiste(fRepEnCours() + ["\"] + "ConfigTDB.tdb") ALORS
sMaConfig = fChargeTexte(fRepEnCours() + ["\"] + "ConfigTDB.tdb")
TDBChargeConfiguration(TDB_FuseauxHoraires, sMaConfig)
FIN
AndroidiPhone/iPad
// Récupération d'un fichier précédemment sauvé
SI fFichierExiste(fRepEnCours() + ["\"] + "ConfigTDB.tdb") ALORS
sMaConfig = fChargeTexte(fRepEnCours() + ["\"] + "ConfigTDB.tdb")
TDBChargeConfiguration(TDB_FuseauxHoraires, sMaConfig)
FIN
Syntaxe
<Résultat> = TDBChargeConfiguration(<Champ Tableau de bord> , <Configuration>)
<Résultat> : Booléen
  • Vrai si la configuration a été chargée.
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Champ Tableau de bord> : Nom de champ
Nom du champ Tableau de bord à manipuler.
<Configuration> : Chaîne de caractères (avec guillemets)
Configuration à restaurer. Cette configuration est le résultat de la fonction TDBSauveConfiguration.
Attention : Si le format de ce paramètre est invalide ou ne peut pas être appliqué au champ Tableau de bord (par exemple parce que les fenêtres/pages internes ou le nombre de colonnes ne correspondent pas), <Résultat> vaut Faux.
Remarques
Les Widgets déclarés visibles depuis la dernière sauvegarde doivent être visibles au chargement de la configuration.
Liste des exemples associés :
WD Tableau de bord Exemples didactiques (WINDEV) : WD Tableau de bord
[ + ] L'exemple "WD Tableau de bord" est un exemple didactique sur l'utilisation du champ Tableau de bord.
Cet exemple présente comment :
- manipuler le champ en mode "édition",
- sauver/charger une configuration,
- configurer le champ (configuration initiale, ajout / suppression de widgets, ...),
- rafraîchir un widget,
- etc.
WW_TableauDeBord Exemples didactiques (WEBDEV) : WW_TableauDeBord
[ + ] L'exemple "WW_TableauDeBord" est un exemple didactique sur l'utilisation du champ Tableau de bord.
Cet exemple présente comment :
- manipuler le champ en mode "édition",
- sauver/charger une configuration,
- configurer le champ (configuration initiale, ajout / suppression de widgets, ...),
- rafraîchir un widget.
Composante : wd250obj.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire