PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Exécute une action sur le service UPnP.
Exemple
MonService est un upnpService
...
 
SELON TableOccurrence(TABLE_ParamIN)
CAS 0
tabRésultat = UPNPExécuteAction(MonService, SAI_Action)
SI ErreurDétectée ALORS
Info(ErreurInfo(errComplet))
RETOUR
FIN
CAS 1
tabRésultat = UPNPExécuteAction(MonService, SAI_Action, ...
TABLE_ParamIN[1].COL_Param)
SI ErreurDétectée ALORS
Info(ErreurInfo(errComplet))
RETOUR
FIN
CAS 2
tabRésultat = UPNPExécuteAction(MonService, SAI_Action, ...
TABLE_ParamIN[1].COL_Param, ...
TABLE_ParamIN[2].COL_Param)
SI ErreurDétectée ALORS
Info(ErreurInfo(errComplet))
RETOUR
FIN
AUTRE CAS
Info("Non géré")
RETOUR
FIN
Syntaxe
<Résultat> = UPNPExécuteAction(<Service> , <Action> [, <Paramètre 1> [... [, <Paramètre N>]]])
<Résultat> : Tableau de chaîne de caractères
Variable de type Tableau de chaînes contenant le résultat de l'action UPnP exécutée.
<Service> : Variable de type upnpService
Nom de la variable de type upnpService correspondant au service sur lequel l'action doit être effectuée.
<Action> : Chaîne de caractères (avec guillemets)
Action à appeler sur le service.
<Paramètre 1> : Type de la valeur attendu (optionnel)
Premier paramètre à passer au service UPnP.
<Paramètre N> : Type de la valeur attendu (optionnel)
Nième paramètre à passer au service UPnP.
Remarques
Si l'action n'est pas exécutée, la variable ErreurDétecté est à Vrai et la fonction ErreurInfo permet de connaître le détail de l'erreur.
Composante : wd240device.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire