PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple de la fonction EnModeAndroid
EnModeAndroid (Exemple)
Exemple de la fonction EnModeAndroid
Cet exemple permet d'utiliser une base de données SQLite sur Android avec accès à la base depuis un PC lors de la connexion de l'appareil en USB.
La base de données sera stockée sur la SD Card de l'appareil.
// CnxBaseSQLite est le nom de la connexion définie dans l'analyse

// Répertoire(s) sur la SD Card d'accès à la base SQLite
sRepertoiredesDonnées est une chaîne = "data_wm_androidbasesqlitepartagepc"
// Nom de la base SQLite
sNomBaseSQLite est une chaîne = "wm_basesqlite.db"
// Unité correspondant à la SD Card de l'appareil Android (depuis une application Windows)
// A demander à l'utilisateur, et à mémoriser dans un fichier de paramètre
sUniteSDCardDepuisPC est une chaîne = "e:"

// Dans tous les cas, la base est au format SQLite (seul format supporté par Android)
CnxBaseSQLite..Provider = hAccèsNatifSQLite

// Exécution sur le mobile Android ?
SI EnModeAndroid() = Vrai ALORS
// oui
// simulateur WINDEV Mobile ?
SI EnModeSimulateur() = Vrai ALORS
// Base dans le répertoire Exe du projet
CnxBaseSQLite..Source = fRepExe() + ["\"] + sNomBaseSQLite
SINON
// Exécution su l'appareil Android ou un émulateur
// (donc il y a normalement la carte de stockage si elle est dispo)
SI SysEtatCarteStockage() = sysCarteDisponible ALORS
// Localise la base de données sur la SD Card, relativement au mobile
CnxBaseSQLite..Source = SysRepCarteStockage() + ["/"] + ...
sRepertoiredesDonnées + ["/"] + sNomBaseSQLite
SINON
// Pas de carte de stockage
Erreur("Il n'y a pas de carte de stockage disponible en écriture sur cet appareil")
FinProgramme()
FIN
FIN
SINON
// Exécution sur un PC ?
SI EnModePocket() = Vrai _OU_ EnModeEmulateurWindowsPhone() = Vrai ALORS
Erreur("Accès à la base non prévu sur cette plateforme d'exécution")
FinProgramme()
SINON
// SI SysVersionWindows() DANS
// ("98","NT 3.5","NT 4", "NT 5","ME","2003S","2008S","VISTA","7")  ALORS
// localise la base de données sur la SD Card, relativement au PC
CnxBaseSQLite..Source = sUniteSDCardDepuisPC + ["\"] + ...
sRepertoiredesDonnées + ["\"] + sNomBaseSQLite
FIN
FIN

// Ouverture de la connexion
SI HOuvreConnexion(CnxBaseSQLite) = Faux ALORS
Erreur("Echec de la connexion à la base de données SQLite Android", HErreurInfo())
FinProgramme()
FIN

HCréationSiInexistant("*")

Info("Connexion effectuée à la base")
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire