PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Ajout d'un rendez-vous dans un calendrier spécifique
RendezVousListeCalendrier (Exemple)
Ajout d'un rendez-vous dans un calendrier spécifique
AndroidWidget Android Cet exemple permet d'ajouter un rendez-vous dans un calendrier spécifique.
// Ajouter un rendez-vous dans un calendrier spécifique

SAI_DateDébut est une Date
SAI_HeureDébut est une Heure
SAI_DateFin est une Date
SAI_HeureFin est une Heure
gRDV est un RendezVous
gCal est un Calendrier
tabCalendrier est tableau de Calendrier

tabCalendrier = RendezVousListeCalendrier()
POUR CHAQUE CalendrierEnCours DE tabCalendrier
SI CalendrierEnCours..Nom = "Le calendrier dans lequel on souhaite faire cet ajout" ALORS
gCal = CalendrierEnCours
SORTIR
FIN
FIN

SAI_DateDébut = DateSys()
SAI_HeureDébut = HeureSys()
SAI_DateFin = DateSys()
SAI_DateFin..Jour += 2
SAI_HeureFin = HeureSys()

// Ajoute un nouveau rendez-vous
gRDV..Titre = "Le titre"
gRDV..DateDébut = SAI_DateDébut + SAI_HeureDébut
gRDV..DateFin = SAI_DateFin + SAI_HeureFin
gRDV..Lieu = "Le lieu"
gRDV..Contenu = "Ma description"
gRDV..FuseauHoraire = ""
gRDV..Auteur = "L'auteur"
gRDV..Invité = "L'invité"
gRDV..JournéeEntière = Vrai

SI RendezVousAjoute(gCal, gRDV) = Vrai ALORS
ToastAffiche("Rendez-vous ajouté")
SINON
Erreur(ErreurInfo())
FIN
Version minimum requise
  • Version 18
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire