PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Dessiner un graphe de surface
grSurfaceCouleurAltitude (Exemple)
Dessiner un graphe de surface
Cet exemple permet de dessiner un graphe de surface représentant la luminosité d'une image. Le graphe est dessiné dans le champ "GRF_Surface".
x, y, z sont des réels
wImage est une Image
 
// Chargement de la photo en mémoire dans une variable de type Image
wImage = "couchersoleil.jpg"
 
// Affichage de la photo
IMG_photo = wImage
 
// Effacement le graphe précédent
grEffaceDessin(GRF_Surface)
// Suppression des données du graphe précédent
grSupprimeSérie(GRF_Surface)
 
// Suppression des différentes couleurs des altitudes précédentes
grSurfaceSupprimeCouleurAltitude(GRF_Surface, 0)
grSurfaceSupprimeCouleurAltitude(GRF_Surface, 33)
grSurfaceSupprimeCouleurAltitude(GRF_Surface, 66)
grSurfaceSupprimeCouleurAltitude(GRF_Surface, 100)
 
 
SI INT_Couleur ALORS
// Graphe en couleur
grSurfaceCouleurAltitude(GRF_Surface, 0, BleuPastel)
grSurfaceCouleurAltitude(GRF_Surface, 33, VertPastel)
grSurfaceCouleurAltitude(GRF_Surface, 66, JaunePastel)
grSurfaceCouleurAltitude(GRF_Surface, 100, RougePastel)
SINON
// Graphe en Noir & Blanc
grSurfaceCouleurAltitude(GRF_Surface, 0, Noir)
grSurfaceCouleurAltitude(GRF_Surface, 100, Blanc)
FIN
 
// Balayage de l'image et de tous les points
// pour déterminer le taux de luminosité du point
// à l'aide de la fonction CouleurLuminosité
POUR i = 1 _À_ wImage..Largeur PAS 4
POUR j = 1 _À_ wImage..Hauteur PAS 4
x = i
y = j
z = CouleurLuminosité(dPixelCouleur(wImage, x, y))
grSurfaceAjouteDonnée(GRF_Surface, x, y, z)
FIN
FIN
 
// Effectue une légère rotation de 35°
// pour mettre en évidence l'effet de relief
grRotation(GRF_Surface, grAxeX, -35)
 
// Dessine le graphe dans le champ Graphe
grDessine(GRF_Surface)
Version minimum requise
  • Version 18
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire