DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
CertificatSigneExécutable (Fonction)
En anglais : CertificateSignExecutable
Signe un fichier exécutable avec un certificat. La signature est intégrée au fichier.
Exemple
// Ouverture du sélecteur de certificat de Windows
MonCertificat est un Certificat
MonCertificat = CertificatSélecteur()
 
// Annulation ou erreur
SI MonCertificat = Null ALORS
RETOUR
FIN
 
// Si le certificat sélectionné n'est pas valide pour signer
SI PAS MonCertificat.ValidePourSignature ALORS
Info("Le certificat sélectionné ne permet de pas de générer une signature.")
RETOUR
FIN
 
// Récupération du buffer contenant la signature
SI PAS CertificatSigneExécutable(sNomCompletFichier, MonCertificat) ALORS
Erreur("Erreur de signature de l'exécutable : " + RC + ErreurInfo())
FIN
Syntaxe
<Résultat> = CertificatSigneExécutable(<Exécutable> , <Certificat> [, <Description> [, <Algorithme>]])
<Résultat> : Booléen
  • Vrai si l'exécutable a été signé,
  • Faux dans le cas contraire. Pour connaître le libellé de l'erreur, utilisez la fonction ErreurInfo avec la constante errMessage.
<Exécutable> : Chaîne de caractères
Nom complet du fichier exécutable à signer.
<Certificat> : Variable de type Certificat
Nom de la variable de type Certificat contenant le certificat à utiliser pour signer l'exécutable.
<Description> : Chaîne de caractères optionnelle
Texte affiché par la fenêtre de l'UAC lors du lancement de l'exécutable.
<Algorithme> : Constante de type Entier
Algorithme de hachage utilisé par la signature :
certSHA160
(Valeur par défaut)
Algorithme également appelé SHA1.
certSHA256Algorithme également appelé SHA2.
Remarque : Cet algorithme n'est pas reconnu sous Windows Vista. L'UAC n'affiche aucune information et l'exécutable peut être lancé.
Classification Métier / UI : Code métier
Composante : wd280std.dll
Version minimum requise
  • Version 18
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire