PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
CertificatSigneExécutable (Fonction)
En anglais : CertificateSignExecutable
Signe un fichier exécutable avec un certificat. La signature est intégrée au fichier.
Exemple
// Ouverture du sélecteur de certificat de Windows
MonCertificat est un Certificat
MonCertificat = CertificatSélecteur()

// Annulation ou erreur
SI MonCertificat = Null ALORS
RETOUR
FIN

// Si le certificat sélectionné n'est pas valide pour signer
SI PAS MonCertificat..ValidePourSignature ALORS
Info("Le certificat sélectionné ne permet de pas de générer une signature.")
RETOUR
FIN

// Récupération du buffer contenant la signature
SI PAS CertificatSigneExécutable(sNomCompletFichier, MonCertificat) ALORS
Erreur("Erreur de signature de l'exécutable : " + RC + ErreurInfo())
FIN
Syntaxe
<Résultat> = CertificatSigneExécutable(<Exécutable> , <Certificat> [, <Description>])
<Résultat> : Booléen
  • Vrai si l'exécutable a été signé,
  • Faux dans le cas contraire. Pour connaître le libellé de l'erreur, utilisez la fonction ErreurInfo avec la constante errMessage.
<Exécutable> : Chaîne de caractères (avec guillemets)
Nom complet du fichier exécutable à signer.
<Certificat> : Variable de type Certificat
Nom de la variable de type Certificat contenant le certificat à utiliser pour signer l'exécutable.
<Description> : Chaîne de caractères optionnelle (entre guillemets)
Versions 22 et supérieures
Texte affiché par la fenêtre de l'UAC lors du lancement de l'exécutable.
Nouveauté 22
Texte affiché par la fenêtre de l'UAC lors du lancement de l'exécutable.
Texte affiché par la fenêtre de l'UAC lors du lancement de l'exécutable.
Composante : wd250std.dll
Version minimum requise
  • Version 18
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire