PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


  • Cas particuliers
  • Procédure WLangage
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Déclenche la surveillance d'un fichier. En cas de modification du fichier, une procédure spécifique est exécutée dans un thread.
Exemple
// Nom du fichier à surveiller
sNomFichier est une chaîne = "C:\Temp\MonRep\MonFichier.extension"
// La procédure TraiteModification sera appelée lorsque le fichier
// "C:\Temp\MonRep\MonFichier.extension" sera modifié.
SI fSurveilleFichier(sNomFichier, fSurveilleFichier_Callback, ...
fsCréationFichier + fsModificationFichier + fsSuppressionFichier + ...
fsRenommage) ALORS
// On informe l'utilisateur de la mise sous surveillance du fichier
Info("La mise sous surveillance du fichier " + sNomFichier + " a réussi.")
SINON
// On informe l'utilisateur de l'échec de la mise sous surveillance du fichier
Info("La mise sous surveillance du fichier " + sNomFichier + " a échoué.")
FIN
 
// Code de la procédure
PROCÉDURE INTERNE fSurveilleFichier_Callback(sNomComplet, sNomFichier, nAction, sAncienNomFichier)
sDesignationAction est une chaîne
// La désignation de l'action subie dépend de nAction
SELON nAction
CAS fsCréationFichier : sDesignationAction = "Création de fichier"
CAS fsSuppressionFichier : sDesignationAction = "Suppression de fichier"
CAS fsModificationFichier : sDesignationAction = "Modification de fichier"
CAS fsRenommage : sDesignationAction = "Renommage de fichier"
FIN
// Ajout d'une ligne contenant les informations de la modification
// dans le champ Table TABLE_MODIFICATIONS
TableAjouteLigne(TABLE_MODIFICATIONS, sNomComplet, sNomFichier, ...
sDesignationAction, sAncienNomFichier)
FIN
Syntaxe
<Résultat> = fSurveilleFichier(<Fichier à surveiller> , <Procédure WLangage> [, <Modifications à notifier>])
<Résultat> : Booléen
  • Vrai si la surveillance du fichier est activée,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Fichier à surveiller> : Chaîne de caractères
Nom complet du fichier à surveiller.
<Procédure WLangage> : Nom de procédure
Nom de la procédure WLangage (également nommée "callback") appelée lors d'un changement sur le fichier spécifié.
Pour plus de détails sur cette procédure, consultez Paramètres de la procédure utilisée par la fonction fSurveilleFichier.
<Modifications à notifier> : Constante ou combinaison de constantes optionnelle de type Entier
Modifications du fichier à surveiller et pour lesquelles la procédure doit être exécutée :
fsCréationFichierCréation du fichier <Nom du fichier modifié>.
fsModificationFichierModification du fichier <Nom du fichier modifié>.
fsRenommageRenommage du fichier <Nom du fichier modifié>.
fsSuppressionFichierSuppression du fichier <Nom du fichier modifié>.
fsToutSurveillance de toutes les actions possibles. Correspond à fsCréationFichier + fsModificationFichier + fsRenommage + fsSuppressionFichier.
Remarques

Cas particuliers

  • Pour arrêter la surveillance du fichier, utilisez les fonctions fSurveilleStop et fSurveilleStopTout.
  • Pour surveiller les modifications effectuées sur le contenu d'un répertoire, utilisez la fonction fSurveilleRépertoire.
  • Limitations :
    • Seuls 5 fichiers peuvent être surveillés simultanément.
    • Il n'est pas possible de surveiller un fichier situé à la racine d'un disque (pour des raisons de performances).

Procédure WLangage

La procédure WLangage est exécutée dans un thread WLangage.
Attention : Il n'est pas possible d'exécuter dans les threads les traitements suivants :
Pour plus de détails sur la gestion des threads, consultez Gestion des threads.
Composante : wd280std.dll
Version minimum requise
  • Version 18
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire