PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Cherche une chaîne de caractères ou un buffer dans un fichier ouvert avec la fonction fOuvre.
Exemple
MonBuffer est un Buffer
IDFichier est un entier
nPosition est un entier
 
MonBuffer = fChargeBuffer("C:\tmp\Page1.html")
IDFichier = fOuvre("C:\test\MonFichier.html")
nPosition = fCherche(IDFichier, MonBuffer)
 
SI nPosition <> -1 ALORS
Info("Le contenu de Page1 a été trouvé dans MonFichier à la position " + nPosition)
FIN
Nouveauté 28
MonBuffer est un Buffer
MonFichier est un FichierDisque
nPosition est un entier
 
MonBuffer = fChargeBuffer("C:\tmp\Page1.html")
MonFichier = fOuvre("C:\test\MonFichier.html")
nPosition = fCherche(MonFichier, MonBuffer)
 
SI nPosition <> -1 ALORS
Info("Le contenu de Page1 a été trouvé dans MonFichier à la position " + nPosition)
FIN
Syntaxe
<Résultat> = fCherche(<Fichier manipulé> , <Elément recherché> [, <Position de départ>])
<Résultat> : Entier
  • Position de l'élément recherché dans le fichier.
  • -1 si aucun élément ne correspond à la recherche.
<Fichier manipulé> : Entier ou variable de type FichierDisque
<Elément recherché> : Buffer ou chaîne de caractères
Buffer ou chaîne de caractères dont le contenu doit être recherché dans le fichier texte.
<Position de départ> : Entier optionnel
Position de départ de la recherche. Par défaut, la recherche est effectuée à partir du début du fichier.
Classification Métier / UI : Code métier
Composante : wd280std.dll
Version minimum requise
  • Version 18
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire