PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Cas d'erreurs possibles :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
<Variable gglConnexion>.ListeDocument (Fonction)
En anglais : <gglConnection variable>.ListDocument
Récupère la liste des documents disponibles sur le serveur Google pour l'utilisateur en cours.
Exemple
// Connexion
Cnx est un gglConnexion
...
SI Cnx.Connecte() = Faux ALORS
Erreur(ErreurInfo())
FIN
...
 
// Liste de tous les documents
tabDocuments est un tableau de 0 gglDocument dynamique
 
// Liste les documents contenant le texte "Test"
tabDocuments = Cnx.ListeDocument("fullText contains 'Test'")
 
// Affiche le titre de chaque document listé
Doc est un gglDocument dynamique
POUR TOUT Doc DE tabDocuments
 Trace(Doc.Titre)
FIN
Syntaxe
<Résultat> = <Connexion Google>.ListeDocument([<Recherche à effectuer>])
<Résultat> : Tableau de variables de type gglDocument
Tableau de variables de type gglDocument : chaque élément du tableau contient les caractéristiques d'un document présent sur le serveur Google.
<Connexion Google> : Variable de type gglConnexion
Nom de la variable de type gglConnexion à utiliser. Cette connexion a été validée avec la fonction <Variable gglConnexion>.Connecte.
<Recherche à effectuer> : Chaîne de caractères (avec guillemets)
Formule de recherche. Pour connaître les paramètres utilisables, consultez la documentation de l'API "Drive" : https://developers.google.com/drive/web/search-parameters
Remarques

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
Liste des exemples associés :
Accès aux Documents Google Exemples unitaires (WINDEV) : Accès aux Documents Google
[ + ] Utilisation des fonctions gglXxx pour accéder aux documents définis dans votre compte Google.
Composante : wd260ggl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire