PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie la liste des destinataires d'une notification par email. Cette notification est envoyée par le serveur HFSQL lorsqu'il rencontre un problème. Remarque : A partir de la version 19, HFSQL est le nouveau nom de HyperFileSQL.
Exemple
cnxConnexionCS est une Connexion
cnxConnexionCS..Provider = hAccèsHFClientServeur
cnxConnexionCS..Utilisateur = "admin"
cnxConnexionCS..MotDePasse = ""
cnxConnexionCS..Serveur = "test:4900"
HOuvreConnexion(cnxConnexionCS)
 
ListeDestEmail est une chaîne
ListeDestEmail = HNotifListeDestinataireEmail(cnxConnexionCS)
 
POUR TOUT CHAÎNE UnDestinataire DE ListeDestEmail SÉPARÉE PAR RC
sDestinataire est une chaîne = ExtraitChaîne(UnDestinataire, 1, TAB)
Notif est un entier = ExtraitChaîne(UnDestinataire, 2, TAB)
NiveauNotif est une chaîne
SELON Notif
CAS hNotifErreur : NiveauNotif = "Niveau minimal : Erreurs"
CAS hNotifAvertissement : NiveauNotif = "Niveau minimal : Avertissement"
CAS hNotifCritique : NiveauNotif = "Niveau minimal : Critique"
FIN
Trace(sDestinataire + TAB + NiveauNotif)
FIN
Syntaxe
<Résultat> = HNotifListeDestinataireEmail(<Connexion>)
<Résultat> : Chaîne de caractères
Liste des destinataires de la notification par email. La liste est de la forme :
<Adresse email du destinataire> + TAB + <Niveau de notification> + RC + ...

où :
  • <Adresse email du destinataire> : chaîne de caractères correspondant à l'adresse email du destinataire.
  • <Niveau de notification> : constante de type entier correspondant au niveau minimum de gravité du problème à partir duquel une notification est envoyée. Les valeurs disponibles sont les suivantes :
    hNotifAvertissementLes notifications seront envoyées dès le niveau avertissement (pour les problèmes de type avertissement, critique et erreur).
    hNotifCritiqueLes notifications seront envoyées dès le niveau critique (pour les problèmes de type critique et erreur).
    hNotifErreurLes notifications seront envoyées seulement pour les problèmes de type erreur.
<Connexion> : Chaîne de caractères (avec ou sans guillemets) ou variable de type Connexion
Connexion à manipuler. Cette connexion correspond :
Composante : wd250hf.dll
Version minimum requise
  • Version 18
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire