PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Imprime un texte au format HTML dans une zone rectangulaire. L'impression n'est pas lancée (seule la fonction iFinImprime permet de lancer l'impression).
Exemple
iAperçu(iPage)

// Récupération de la hauteur de la zone
dHauteur est un réel
dHauteur = iHauteurZone(sTexteHTML, 100, iHTML)

// Trace un cadre
iCadre(0,0, 200, dHauteur*2)

// Impression du HTML dans le cadre
iImprimeZoneHTML(sTexteHTML, 0, 0, 200, dHauteur*2)

iFinImprime()
// Impression de HTML sur plusieurs pages
PROCÉDURE ImprimeZoneHTMLMultiPage(LOCAL sHTMLàImprimerEnUTF8 est une chaîne ANSI,
LOCAL x1 est un réel = 0,LOCAL y1 est un réel = iPosY(),
LOCAL x2 est un réel = iLargeurPage() - x1)
// Variables de travail
nElémentDébut est un entier = 0
nElémentFin est un entier = 0
rHauteurRestante est un réel = 0
rDernièreHauteurImprimée est un réel = 0
 
// Boucle pour imprimer tous les "éléments" du HTML
BOUCLE
// Hauteur de ce qui reste à imprimer
rHauteurRestante = iHauteurZone(sHTMLàImprimerEnUTF8, x2-x1, iHTML, nElémentDébut + 1)
SI rHauteurRestante <= 0 ALORS
// Plus rien à imprimer
// On positionne le "curseur d'impression" après ce qui a été imprimé
iPosY(y1 + rDernièreHauteurImprimée)
SORTIR
FIN
// Mémorise la dernière hauteur imprimée
rDernièreHauteurImprimée = rHauteurRestante
// Si ce n'est pas le début, on saute à la page suivante
SI nElémentDébut > 0 ALORS
iSautePage()
// On repart donc en haut de la page
y1 = 0
FIN
// Imprime effectivement tout ce qui rentre dans la zone
nElémentFin = iImprimeZoneHTML(sHTMLàImprimerEnUTF8, x1, y1, ...
x2, iHauteurPage(), nElémentDébut + 1)
// On continue à partir de l'élément suivant
nElémentDébut = nElémentFin
FIN
Syntaxe
<Résultat> = iImprimeZoneHTML(<Texte HTML> , <X1> , <Y1> , <X2> , <Y2> [, <Début> [, <Fin>]])
<Résultat> : Entier
Indice du dernier élément HTML imprimé dans la zone rectangulaire (comptage spécifique de WINDEV/WEBDEV).
<Texte HTML> : Chaîne de caractères
Chaîne de caractères au format HTML à imprimer dans une zone spécifique. Cette chaîne de caractères doit être au format UTF8. Utilisez si nécessaire la fonction ChaîneVersUTF8 pour effectuer la conversion.
<X1> : Réel
Coordonnée horizontale (colonne ou abscisse) du coin haut gauche de la zone d'impression (en millimètres).
Valeur comprise entre 0 et la largeur de la page (donnée par iLargeurPage).
<Y1> : Réel
Coordonnée verticale (ligne ou ordonnée) du coin haut gauche de la zone d'impression (en millimètres).
Valeur comprise entre 0 et la hauteur de la page (donnée par iHauteurPage).
<X2> : Réel
Coordonnée horizontale (colonne ou abscisse) du coin bas droit de la zone d'impression (en millimètres).
Valeur comprise entre 0 et la largeur de la page (donnée par iLargeurPage).
<Y2> : Réel
Coordonnée verticale (ligne ou ordonnée) du coin bas droit de la zone d'impression (en millimètres).
Valeur comprise entre 0 et la hauteur de la page (donnée par iHauteurPage).
<Début> : Entier optionnel
Indice du premier élément HTML du <Texte HTML> à imprimer. Si ce paramètre n'est pas indiqué, le <Texte HTML> est imprimé depuis le premier élément HTML.
<Fin> : Entier optionnel
Indice du dernier élément HTML du <Texte HTML> à imprimer. Si ce paramètre n'est pas indiqué, le <Texte HTML> est imprimé jusqu'au dernier élément HTML.
Composante : wd260prn.dll
Version minimum requise
  • Version 18
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire