PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Prise de photos avec miniature
VidéoGénèreMiniature (Exemple)
Prise de photos avec miniature
Cet exemple permet de prendre des photos avec génération d'une miniature.
Rappel : Si des photos doivent être utilisées dans des applications Android, il est conseillé de travailler avec des miniatures et non les photos originales prises par l'appareil.
sFichierImage est une chaîne
sMiniature est une chaîne
 
// Prend une photo avec la caméra de l'appareil Android
sFichierImage = VidéoLanceAppli(viCaptureImage)
SI sFichierImage = "" ALORS
Erreur("Impossible de prendre la photo. ", ErreurInfo())
RETOUR
FIN
 
// Génère une miniature à partir de la photo prise par l'appareil
// et affiche la miniature dans un champ Image
sMiniature = fExtraitChemin(sFichierImage, fDisque + fRépertoire + fFichier) + "_thumb.jpg"
SI VidéoGénèreMiniature(sFichierImage, sMiniature) = Vrai ALORS
IMG_Photo = sMiniature
SINON
Erreur("Impossible de générer la miniature.", ErreurInfo())
FIN
Version minimum requise
  • Version 17
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire