PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Ajout de contacts dans une session Lotus Notes
  • Ajout de contacts dans la liste des contacts de l'appareil Andoid
ContactAjoute (Exemple)
Ajout de contacts dans une session Lotus Notes
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)Ajax Cet exemple permet d'ajouter un contact dans une session Lotus Notes. Cet exemple utilise la structure mContact pour réaliser cet ajout.
// Ouverture d'une session Lotus Notes
IDSession est un entier
IDSession = EmailOuvreSessionNotes("MotDePasse", "ServeurMars", ...
"mail/julie.nsf", "C:\Lotus Notes\julie.id")
// Initialisation des variables de la structure Contact
ContactRAZ()
// Renseignements des variables pour le nouveau contact
mContact.Nom = "Dupont"
mContact.Prénom = "Axelle"
mContact.Email = "axelle.dupont@mesmails.com"
// Ajout du contact
SI ContactAjoute(IDSession) = Vrai ALORS
Info("Contact ajouté")
SINON
Erreur("Erreur lors de l'ajout", ErreurInfo())
FIN
Ajout de contacts dans la liste des contacts de l'appareil Andoid
AndroidWidget Android Cet exemple permet d'ajouter un contact dans la liste des contacts de l'appareil Android. Les renseignements concernant le contact sont saisis dans la fenêtre FEN_NouveauContact. Le code suivant correspond à la validation de cette fenêtre.
// Variables locales
tContact est un Contact
tTéléphone est un Téléphone
tEmail est une AdresseEmail
 
// Identité
tContact.Nom = SAI_Nom
tContact.Prénom = SAI_Prénom
 
// Numéros de téléphone
// Fixe
SI SAI_TéléphoneFixe <> "" ALORS
tTéléphone.Numéro = SAI_TéléphoneFixe
tTéléphone.Type = telDomicile
Ajoute(tContact.Téléphone, tTéléphone)
FIN
 
// Mobile
SI SAI_TéléphoneMobile <> "" ALORS
tTéléphone.Numéro = SAI_TéléphoneMobile
tTéléphone.Type = telMobileDomicile
Ajoute(tContact.Téléphone, tTéléphone)
FIN
 
// Email
SI SAI_Email <> "" ALORS
tEmail.Adresse = SAI_Email
tEmail.Type = emailDomicile
Ajoute(tContact.Email, tEmail)
FIN
 
// Ajout
SI PAS ContactAjoute(tContact, gSource) ALORS
Erreur("Impossible de créer le contact")
SINON
FEN_TableContacts.RafraichitListeContact()
Ferme()
FIN
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire