PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Présentation
  • Mise en place
  • Gestion des miniatures
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
Si votre appareil Android ou iOS dispose d'une fonction Caméra, il est possible de piloter la caméra depuis votre application Android ou iOS. Vous pouvez ainsi visualiser et/ou prendre des photos ou des séquences vidéo.
Versions 21 et supérieures
Remarque : Le champ Caméra permet également de décoder les codes-barres. Pour plus de détails, consultez : Champ Caméra : décoder les codes-barres.
Nouveauté 21
Remarque : Le champ Caméra permet également de décoder les codes-barres. Pour plus de détails, consultez : Champ Caméra : décoder les codes-barres.
Remarque : Le champ Caméra permet également de décoder les codes-barres. Pour plus de détails, consultez : Champ Caméra : décoder les codes-barres.
Mise en place
Pour manipuler la caméra d'un appareil Android ou iOS, il est possible :
Android

Gestion des miniatures

Si des photos doivent être utilisées dans des applications Android, il est conseillé de travailler avec des miniatures et non les photos originales prises par l'appareil. Ces miniatures peuvent être générées grâce à la fonction VidéoGénèreMiniature (ou CaméraGénèreMiniature).
Cet exemple permet de prendre des photos avec génération d'une miniature (utilisation des fonctions Vidéoxxx).
sFichierImage est une chaîne
sMiniature est une chaîne

// Prend une photo avec la caméra de l'appareil Android
sFichierImage = VidéoLanceAppli(viCaptureImage)
SI sFichierImage = "" ALORS
Erreur("Impossible de prendre la photo.", ErreurInfo())
RETOUR
FIN

// Génère une miniature à partir de la photo prise par l'appareil
// et affiche la miniature dans un champ Image
sMiniature = fExtraitChemin(sFichierImage, fDisque + fRépertoire + fFichier) + "_thumb.jpg"
SI VidéoGénèreMiniature(sFichierImage, sMiniature) = Vrai ALORS
IMG_Photo = sMiniature
SINON
Erreur("Impossible de générer la miniature.", ErreurInfo())
FIN
Liste des exemples associés :
WM Note de frais Exemples multiplateforme (WINDEV Mobile) : WM Note de frais
[ + ] Cet exemple permet de gérer vos notes de frais.

Voici les principales fonctionnalités de cette application :
- La saisie des factures
- Gestion des devises étrangères
- Ajout de justificatif photo pour les factures
- Envoi par mail de la note de frais
- Suivi des notes de frais
- ...
Version minimum requise
  • Version 17
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire