PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Fonctionnalité d'application requise
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Liste les sources (ou comptes) de contacts enregistrés sur l'appareil.
Exemple
// Liste les comptes Google du téléphone
tabSource est un tableau de ContactSource = ContactListeSource()
SI PAS ErreurDétectée ALORS
POUR TOUT UneSource DE tabSource
SI UneSource.Type = "com.google" ALORS
// Traitement ...
FIN
FIN
FIN
// Initialisation de la Zone répétée ZR_Sources
// Liste les sources
gtabContactSource = ContactListeSource()
 
// Parcours des sources
POUR TOUT UneSource DE gtabContactSource
ZoneRépétéeAjouteLigne(ZR_Sources, UneSource.Nom, DonneTypeSource(UneSource.Type))
FIN
Syntaxe
<Résultat> = ContactListeSource()
<Résultat> : Tableau de variables de type ContactSource
Tableau de variables de type ContactSource initialisé avec la liste des sources (ou comptes) de contacts enregistrés sur l'appareil.
En cas d'erreur, la variable ErreurDétectée est à Vrai. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
Remarques
Universal Windows 10 App

Fonctionnalité d'application requise

L'utilisation de cette fonction entraîne la déclaration d'une fonctionnalité d'application dans l'assistant de génération de l'application.
Fonctionnalité requise : Contacts
Cette fonctionnalité permet aux applications d'accéder aux contacts.
Liste des exemples associés :
WM Gestion Contacts Exemples multiplateforme (WINDEV Mobile) : WM Gestion Contacts
[ + ] Cet exemple illustre la gestion de contacts pour Android et iOS.
Il permet de :
- lister les contacts du téléphone
- appeler les contacts
- envoyer des sms aux contacts
- ...
Composante : wd280android.aar
Version minimum requise
  • Version 17
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire