PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Renvoie des informations sur le type d'un caractère.
Exemple
CaractType("A") // la fonction renvoie ctLettre|ctMajuscule
 
CaractType("é") // la fonction renvoie ctLettre|ctMinuscule|ctAccent
 
// Vérifie si un caractère est une lettre
SI ETBinaire(CaractType("c"), ctLettre) <> 0 ALORS
Trace("Ce caractère est une lettre")
FIN
Syntaxe
<Résultat> = CaractType(<Caractère>)
<Résultat> : Constante ou combinaison de constantes de type Entier
Type du caractère analysé :
ctAccentCaractère accentué ou diacritique.
La constante ctAccent est toujours combinée avec la constante ctLettre.
ctEspaceEspace.
ctLettreLettre.
ctMajusculeCaractère majuscule.
La constante ctMajuscule est toujours combinée avec la constante ctLettre.
ctMinusculeCaractère minuscule.
La constante ctMinuscule est toujours combinée avec la constante ctLettre.
ctNumériqueCaractère numérique.
ctPonctuationCaractère de ponctuation.
<Caractère> : Chaîne de caractères
Caractère à manipuler.
Remarques
  • Le caractère 0 renvoie 0.
  • Certaines informations sur les caractères peuvent être cumulées : un caractère peut être une lettre accentuée. Dans ce cas, les constantes suivantes peuvent être combinées : ctAccent, ctLettre, ctMajuscule et ctMinuscule.
    Pour vérifier une seule information (par exemple, si le caractère est une lettre): il est conseillé de tester la constante correspondante en utilisant la fonction ETBinaire ou l'opérateur "&". Par exemple :
    // Vérifie si un caractère est une lettre
    SI ETBinaire(CaractType("c"), ctLettre) <> 0 ALORS
    Trace("Ce caractère est une lettre")
    FIN
Classification Métier / UI : Code neutre
Composante : wd280vm.dll
Version minimum requise
  • Version 17
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire