PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Permet de savoir si une sous-chaîne est contenue dans une chaîne.
Exemple
sMaChaîne est une chaîne = "Antananarivo"
SI Contient(sMaChaîne, "NA") = Faux ALORS
Info("Cette chaîne ne contient pas la syllabe NA")
FIN
tabChaine est un tableau de chaînes = ["WINDEV","WEBDEV"]
sTest est une chaîne = "WEBDEV 22"
 
SI Contient(sTest, tabChaine) ALORS
Info("Cette chaîne contient WINDEV ou WEBDEV")
FIN
Syntaxe

Savoir si une chaîne contient une sous-chaîne Masquer les détails

<Résultat> = Contient(<Chaîne à analyser> , <Sous-chaîne> [, <Options>])
<Résultat> : Booléen
  • Vrai si la chaîne contient la sous-chaîne.
  • Faux dans le cas contraire.
<Chaîne à analyser> : Chaîne de caractères Ansi, Unicode ou Binaire
Chaîne de caractères à manipuler.
<Sous-chaîne> : Chaîne de caractères Ansi, Unicode ou Binaire
Sous-chaîne à rechercher.
<Options> : Constante de type Entier
Mode de recherche de la sous-chaîne :
MotCompletRecherche un mot complet (entouré par des caractères de ponctuation ou des espaces).
SansCasseRecherche sans tenir compte de la casse (différences majuscules / minuscules) ou des accents.

Par défaut, la recherche de la sous-chaîne est sensible à la casse et cherche toutes les chaînes spécifiées (même si elles font partie d'un mot).

Savoir si une chaîne contient une des chaînes contenue dans un tableau Masquer les détails

<Résultat> = Contient(<Chaîne à analyser> , <Tableau de chaînes à rechercher> [, <Options>])
<Résultat> : Booléen
  • Vrai si la chaîne contient une des chaînes présente dans le tableau.
  • Faux dans le cas contraire.
<Chaîne à analyser> : Chaîne de caractères Ansi, Unicode ou Binaire
Chaîne de caractères à manipuler.
<Tableau de chaînes à rechercher> : Tableau
Nom du tableau contenant les chaînes de caractères à rechercher.
<Options> : Constante de type Entier
Mode de recherche de la sous-chaîne :
MotCompletRecherche un mot complet (entouré par des caractères de ponctuation ou des espaces).
SansCasseRecherche sans tenir compte de la casse (différences majuscules / minuscules) ou des accents.

Par défaut, la recherche de la sous-chaîne est sensible à la casse et cherche toutes les chaînes spécifiées (même si elles font partie d'un mot).
Composante : wd280vm.dll
Version minimum requise
  • Version 17
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire