PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
AnnuleContexteWebservice (Fonction)
En anglais : CancelWebserviceContext
Supprime du contexte du webservice une variable ajoutée par la fonction DéclareContexteWebservice.
Exemple
GLOBAL
gsMaGlobale est une chaîne
 
SI DéclareContexteWebservice(gsMaGlobale) = Faux ALORS
// Initialisation avec la valeur par défaut
gsMaGlobale = ValeurInitiale()
FIN
...
 
// En cas d'erreur supprime la valeur
SI bErreur ALORS
AnnuleContexteWebservice(gsMaGlobale)
FIN
Syntaxe
AnnuleContexteWebservice([<Nom de la variable 1> [... [, <Nom de la variable N>]]])
<Nom de la variable 1> : Type de la variable (paramètre optionnel)
Nom de la première variable à supprimer du contexte.
<Nom de la variable N> : Type de la variable (paramètre optionnel)
Nom de la Nème variable à supprimer du contexte.
Remarques
  • Si la variable n'existe pas, aucune erreur n'est renvoyée.
  • Si aucune variable n'est indiquée, la session complète est annulée : toutes les variables mémorisées sont perdues, et le fichier de session est détruit.
  • Versions 20 et supérieures
    Si votre projet utilise les sessions prélancées, cette fonction ne doit pas être utilisée dans l'événement "Initialisation" du projet. Cette fonction doit être utilisée dans l'événement "Initialisation du projet après connexion au site".
    Nouveauté 20
    Si votre projet utilise les sessions prélancées, cette fonction ne doit pas être utilisée dans l'événement "Initialisation" du projet. Cette fonction doit être utilisée dans l'événement "Initialisation du projet après connexion au site".
    Si votre projet utilise les sessions prélancées, cette fonction ne doit pas être utilisée dans l'événement "Initialisation" du projet. Cette fonction doit être utilisée dans l'événement "Initialisation du projet après connexion au site".
Composante : wd260awws.dll
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire