PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Vérifie la correspondance entre une signature et un fichier. La signature a été conservée sous forme de variable de type Buffer.
Exemple
MonCertificat est un Certificat
 
// Ouverture du sélecteur de certificat de Windows
MonCertificat = CertificatSélecteur()
 
// Annulation ou erreur
SI MonCertificat.Nom = "" ALORS
RETOUR
FIN
 
// Teste si le certificat sélectionné est valide pour signer
SI MonCertificat.ValidePourSignature = Faux ALORS
Info("Le certificat sélectionné ne permet de pas de générer une signature.")
RETOUR
FIN
 
// Récupération du buffer contenant la signature
bufSignature est un Buffer
bufSignature = CertificatSigneFichier(NomCompletFichier, MonCertificat)
 
 
// Vérification de la signature
SELON CertificatVérifieFichierSignatureBuffer(NomCompletFichier, bufSignature)
CAS certificatOk : Info("Signature valide et certificat fiable")
CAS certificatInvalide : Info("Signature ou certificat invalide")
CAS certificatExpiré : Info("Signature valide mais certificat expiré")
CAS certificatNonFiable : Info("Signature valide mais racine de confiance "+  ...
"du certificat non fiable")
FIN
Syntaxe
<Résultat> = CertificatVérifieFichierSignatureBuffer(<Nom du fichier> , <Buffer de signature>)
<Résultat> : Entier
Résultat de la vérification de la signature :
certificatExpiréSignature valide mais certificat expiré.
certificatInvalideSignature ou certificat invalide.
certificatNonFiableSignature valide mais la racine de confiance du certificat est non fiable.
certificatOkSignature et certificat fiables.
<Nom du fichier> : Chaîne de caractères
Nom complet ou relatif du fichier sur lequel la vérification doit être effectuée.
<Buffer de signature> : Buffer
Buffer contenant la signature du fichier. Ce buffer est obtenu avec la fonction CertificatSigneFichier.
Remarques
Composante : wd280std.dll
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire