PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Gestion des certificats en WEBDEV
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
CertificatVérifieFichierSignatureFichier (Fonction)
En anglais : CertificateCheckFileSignatureFile
Vérifie la correspondance entre une signature et un fichier. La signature a été conservée sous forme d'un fichier externe.
Exemple
MonCertificat est un Certificat

// Ouverture du sélecteur de certificat de Windows
MonCertificat = CertificatSélecteur()

// Annulation ou erreur
SI MonCertificat..Nom = "" ALORS
RETOUR
FIN

// Teste si le certificat sélectionné est valide pour signer
SI MonCertificat..ValidePourSignature = Faux ALORS
Info("Le certificat sélectionné ne permet de pas de générer une signature.")
RETOUR
FIN

// Récupération du fichier contenant la signature
bufSignature est un Buffer
bufSignature = CertificatSigneFichier(NomCompletFichier, MonCertificat, MonFichierSignature)


// Vérification de la signature
SELON CertificatVérifieFichierSignatureFichier(NomCompletFichier, MonFichierSignature)
CAS certificatOk : Info("Signature valide et certificat fiable")
CAS certificatInvalide : Info("Signature ou certificat invalide")
CAS certificatExpiré : Info("Signature valide mais certificat expiré")
CAS certificatNonFiable : Info("Signature valide mais racine de confiance " + ...
"du certificat non fiable")
FIN
Syntaxe
<Résultat> = CertificatVérifieFichierSignatureFichier(<Nom du fichier> , <Fichier de signature>)
<Résultat> : Constante de type Entier
Résultat de la vérification de la signature :
certificatExpiréSignature valide mais certificat expiré.
certificatInvalideSignature ou certificat invalide.
certificatNonFiableSignature valide mais la racine de confiance du certificat est non fiable.
certificatOkSignature et certificat fiables.
<Nom du fichier> : Chaîne de caractères (avec guillemets)
Nom complet ou relatif du fichier sur lequel la vérification doit être effectuée.
<Fichier de signature> : Chaîne de caractères (avec guillemets)
Nom complet ou relatif du fichier externe contenant la signature. Ce fichier est créé avec la fonction CertificatSigneFichier.
Remarques
WEBDEV - Code Serveur

Gestion des certificats en WEBDEV

Pour que les certificats soient visibles pour l'utilisateur du site, ils doivent être installés sur le serveur dans le magasin de certificats personnels de l'utilisateur Internet.
Composante : wd240std.dll
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire