PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
DNSSupprimeAdresse (Fonction)
En anglais : DNSDeleteAddress
Supprime une relation Nom/Adresse IP dans un serveur DNS.
Exemple
ResultDNS est un booléen

// Supprime une adresse
ResultDNS = DNSSupprimeAdresse("testAp.towerqual.local.", "192.168.1.1", "Andromede_2")
SI ResultDNS = Faux ALORS
Erreur(ErreurInfo(errComplet))
FIN

// Supprime toutes les adresses
ResultDNS = DNSSupprimeAdresse("testAp.towerqual.local.", "", "Andromede_2")
SI ResultDNS = Faux  ALORS
Erreur(ErreurInfo(errComplet))
FIN
Syntaxe
<Résultat> = DNSSupprimeAdresse(<Nom> [, <Adresse IP> [, <Serveur DNS> [, <Utilisateur> [, <Mot de passe>]]]])
<Résultat> : Booléen
  • Vrai si la suppression a été effectuée,
  • Faux dans le cas contraire. La fonction ErreurInfo permet d'obtenir plus de renseignements sur le problème rencontré.
<Nom> : Chaîne de caractères Unicode (avec guillemets)
Nom à supprimer du DNS. Ce paramètre est de la forme : <Nom du poste> + "." + <Domaine>. Exemple : "testdoc.pcsoft.com"
<Adresse IP> : Chaîne de caractères (avec guillemets) optionnelle
Adresse IP associée au nom à supprimer. Cette adresse IP peut être une adresse IP version 4 (au format xxx.xxx.xxx.xxx) ou version 6 (au format aaaa :bbbb :cccc :dddd :eeee :ffff :gggg :hhhh :iiii :jjjj).
Si ce paramètre correspond à une chaîne vide (""), toutes les associations du nom avec une adresse IP seront supprimées.
<Serveur DNS> : Chaîne de caractères (avec guillemets) optionnelle
Adresse du serveur DNS à mettre à jour. L'association "Adresse IP / Nom" sera supprimée de ce serveur. Par défaut, le serveur DNS actuel est utilisé.
<Utilisateur> : Chaîne de caractères Unicode (avec guillemets) optionnelle
Nom de l'utilisateur utilisé pour signer la requête.
<Mot de passe> : Chaîne de caractères Unicode (avec guillemets) optionnelle
Mot de passe associé à l'utilisateur pour signer la requête.
Remarques
  • Cette fonction gère les serveurs DNS Linux et Windows ne nécessitant pas de signature des requêtes.
  • Cette fonction gère les serveurs DNS Windows nécessitant une signature des requêtes.
Composante : wd250com.dll
Voir Aussi
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire