PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Extrait un certificat d’un buffer de signature ou d’un duplicata d’impression.
Exemple
// Extraction du certificat depuis le buffer
MonCertificat est un Certificat
MonCertificat = CertificatExtrait(bufSignature, certificatDepuisBuffer)

// Teste si la signature ne correspond pas
// ou si le buffer est incorrect (détail dans ErreurInfo)
SI MonCertificat = Null ALORS
Erreur("Erreur lors de la récupération du certificat." + RC + ErreurInfo())
RETOUR
FIN

// Affiche le niveau de fiabilité du certificat
SELON MonCertificat..Fiabilité
CAS certificatOk : Info("Certificat valide")
CAS certificatInvalide : Info("Certificat invalide")
CAS certificatNonFiable : Info("Racine de confiance du certificat non fiable")
CAS certificatExpiré : Info("Dates de validité du certificat expiré")
FIN
Syntaxe
<Résultat> = CertificatExtrait(<Elément signé> [, <Option>])
<Résultat> : Variable de type Certificat
Variable de type Certificat extrait de l'élément contenant la signature.
<Elément signé> : Variable de type Buffer ou chaîne de caractères
Correspond :
<Option> : Constante optionnelle de type Entier
Indique le type d'élément utilisé :
certificatDepuisBuffer
(Valeur par défaut)
L'élément est un buffer de signature.
certificatDepuisDuplicataL'élément est le chemin d'un fichier duplicata signé.
Composante : wd250std.dll
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire