PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Validité du certificat
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Crée la signature d'un fichier. Cette signature peut être mémorisée dans une variable de type Buffer ou bien dans un fichier texte.
Exemple
Etats et Requêtes
MonCertificat est un Certificat

// Ouverture du sélecteur de certificat de Windows
MonCertificat = CertificatSélecteur()

// Annulation ou erreur
SI MonCertificat..Nom = "" ALORS
RETOUR
FIN

// Teste si le certificat sélectionné est pas valide pour signer
SI MonCertificat..ValidePourSignature = Faux ALORS
Info("Le certificat sélectionné ne permet de pas de générer une signature.")
RETOUR
FIN

// Récupération du buffer contenant la signature
bufSignature est un Buffer
bufSignature = CertificatSigneFichier(NomCompletFichier, MonCertificat)

// Sauvegarde de la signature dans un fichier pour une vérification ultérieure
fSauveBuffer(MonFichierDeSignature, bufSignature)
Syntaxe
<Résultat> = CertificatSigneFichier(<Chemin du fichier> , <Certificat> [, <Fichier de signature>])
<Résultat> : Buffer
Signature du fichier. Ce buffer pourra être ensuite utilisé par la fonction CertificatVérifieFichierSignatureBuffer pour vérifier la correspondance entre la signature et le fichier.
<Chemin du fichier> : Chaîne de caractères (avec guillemets)
Nom et chemin complet (ou relatif) du fichier pour lequel une signature doit être créée.
<Certificat> : Variable de type Certificat
Nom de la variable de type Certificat contenant le certificat à utiliser pour créer la signature du fichier.
<Fichier de signature> : Chaîne de caractères optionnelle (avec guillemets)
Nom et chemin complet (ou relatif) du fichier contenant la signature. Ce fichier pourra être ensuite utilisé par la fonction CertificatVérifieFichierSignatureFichier pour vérifier la correspondance entre la signature et le fichier.
Remarques

Validité du certificat

Avant de signer un fichier, il est conseillé de vérifier la validité du certificat (propriété ..ValidePourSignature de la variable de type Certificat). Cette propriété permet de savoir si le certificat possède une clé privée et toutes les caractéristiques requises pour effectuer une signature. Si cette propriété est à Faux, la fonction CertificatSigneFichier renvoie une erreur.
Composante : wd250std.dll
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire