PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
CertificatSélecteur (Fonction)
En anglais : CertificateSelect
Ouvre une fenêtre de sélection de certificats. Les certificats listés sont les certificats installés dans le magasin personnel.
Exemple
MonCertificat est un Certificat

// Ouverture du sélecteur de certificat de Windows
MonCertificat = CertificatSélecteur()

// Annulation ou erreur
SI MonCertificat..Nom = "" ALORS
        RETOUR
FIN
// Teste si le certificat sélectionné est valide pour signer
SI MonCertificat..ValidePourSignature = Faux ALORS
        Info("Le certificat sélectionné ne permet de pas de générer une signature.")
        RETOUR
FIN

// Récupération du buffer contenant la signature
bufSignature est un Buffer
bufSignature = CertificatSigneChaîne("Chaîne de caractères à signer", MonCertificat)

// Récupération du certificat contenu dans le buffer de la signature
MonCertificatExtrait est un Certificat
MonCertificatExtrait = CertificatExtrait(bufSignature)

// Gestion des erreurs
SI MonCertificatExtrait = Null ALORS
        RETOUR
FIN

// Ouverture de la fenêtre des propriétés du certificat
CertificatOuvrePropriétés(MonCertificatExtrait)
Syntaxe
<Certificat> = CertificatSélecteur()
<Certificat> : Variable de type Certificat
Nom de la variable de type Certificat à initialiser.
Si la fenêtre de sélection a été validée, la variable de type Certificat est initialisée avec les valeurs correspondant au certificat choisi.
Si la fenêtre de sélection a été annulée, la variable de type Certificat contient un certificat vide (par exemple son nom n'est pas rempli).
Composante : wd250std.dll
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire