PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Valide un document XML à partir d’un schéma XSD.
Versions 17 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 17
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Nouveauté 18
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Universal Windows 10 App Cette fonction est désormais disponible en mode Windows Store apps.
Versions 21 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
// Validation à partir du schéma défini lors de la déclaration
cMonDoc est un xmlDocument, description = "schemaXSDDuProjet"
SI XMLDocumentValide(cMonDoc) = Faux ALORS
Erreur(ErreurInfo())
SINON
Info("Le document XML est valide")
FIN
// Validation avec le schéma passé en paramètre
cMonDoc2 est un xmlDocument
SI XMLDocumentValide(cMonDoc2, "schemaXSDDuProjet") = Faux ALORS
        Erreur(ErreurInfo())
SINON
        Info("Le document XML est valide")
FIN
Syntaxe
<Résultat> = XMLDocumentValide(<Document XML> [, <Schéma XSD>])
<Résultat> : Booléen
  • Vrai si la validation est réussie,
  • Faux dans le cas contraire. En cas d'erreur, il est possible de connaître le libellé de l'erreur avec la fonction ErreurInfo.
<Document XML> : xmlDocument
Nom de la variable de type xmlDocument contenant le document à valider.
<Schéma XSD> : Chaîne de caractères optionnelle (avec guillemets)
Nom du schéma à utiliser pour valider le document XML.
  • Si ce paramètre est précisé, le schéma XSD indiqué est utilisé pour valider le document.
  • Si ce paramètre n'est pas précisé, le schéma indiqué au moment de la déclaration est utilisé (déclaration utilisant la syntaxe : cMonDoc est un xmlDocument, description="monXSD").
  • Si le schéma indiqué au moment de la déclaration n'est pas valide, une erreur WLangage est affichée.
Remarque : Si le document XML a été déclaré avec une description d'un schéma XSD, la validation est réalisée automatiquement au moment de la sauvegarde par la fonction XMLSauve.
Composante : wd240xml.dll
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Le fichier .xsd doit être dans le repertoire du projet en windev 18
Le fichier contenant le schéma XSD doit être absolument dans le répertoire du projet sinon le xmlDocumentValide ne fonctionne pas.
De même sans la présence de ce fichier dans le repertoire du projet le xmlsauve n'effectuera pas le contrôle de validité par rapport au xsd (du coup l'instruction xmlns ne sera pas ajoutée automatiquement dans votre fichier xml et le format des dates ne seront pas controlé
Gilles FROMONT
07 jan. 2014
Un exemple un peu plus précis
Pour que la validation puisse se faire, il faut dabord charger le fichier dans la variable de type «xmlDocument».



// Validation à partir du schéma «Transmission.xsd» défini lors de la déclaration
// ----------------------------------------------------------------------------------------
lcDoc est un xmlDocument <description = "Transmission"> = XMLOuvre ("P_Relevé_01.XML", depuisFichier)


SI ErreurDétectée ALORS

Info ("Erreur au chargement du fichier.")

SINON
SI PAS XMLDocumentValide (lcDoc) ALORS

Erreur (ErreurInfo ())

SINON
Info ("Le document XML est valide.")
FIN
FIN
Sylvain LaRue ( MRT)
14 déc. 2011