PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Envoi d'un fichier
  • Envoi d'un formulaire avec un fichier à uploader à une page AWP WEBDEV
  • Envoi d'un formulaire (méthode HEAD)
HTTPEnvoieFormulaire (Exemple)
Envoi d'un fichier
HTTPCréeFormulaire("FORM")
HTTPAjouteFichier("FORM", "file[]", ComplèteRep(fRepExe) + "1Fichier.txt", "text/plain")
HTTPAjouteParamètre("FORM", "domain", "0")
HTTPAjouteParamètre("FORM", "submit", "Envoyer")
HTTPEnvoieFormulaire("FORM", "http://Url_a_contacter, httpPost", "", ...
 "Accept: text/html, application/xhtml+xml, image/jxr; */*" + RC + ...
 "Accept-Language: fr-FR" + RC)
Envoi d'un formulaire avec un fichier à uploader à une page AWP WEBDEV
sFormulaire est une chaîne = "FORMULAIRE"
sUrlPageAWP est une chaîne = "http://localhost/WW_MONSITE_WEB/FR/PAGE_WEBDEV_AWP.awp"
 
// Valeur à transmettre
sValeurNom est une chaîne = "Durand"
sFichier est une chaîne = "c:\Mes Projets\AUploader.zip"
 
// Lien/bouton qui fait le traitement
sNomBoutonaExecuter est une chaîne = "LIEN_VALIDE"
sResultat est une chaîne
 
HTTPCréeFormulaire(sFormulaire)
 
// Données du formulaires de la page WEBDEV
// Champs de saisie de la page WEBDEV
HTTPAjouteParamètre(sFormulaire, "SAI_NOM", sValeurNom)
 
// Champ Upload
HTTPAjouteFichier(sFormulaire, "SAI_UPLOAD", sFichier)
 
// Attention au nom des champs WEBDEV :
// 1 - il faut désactiver l'option de compression du nom des champs (..Alias)
// pour la page (ou le projet) WEBDEV dans l'onglet avancé
// 2 - les noms des champs WEBDEV sont toujours en majuscules
 
// Champs spécifiques permettant d'indiquer
// le bouton/lien à exécuter au serveur d'application WEBDEV
HTTPAjouteParamètre(sFormulaire, "WD_BUTTON_CLICK_", sNomBoutonaExecuter)
HTTPAjouteParamètre(sFormulaire, "WD_ACTION_", "")
 
// Envoi du formulaire
SI HTTPEnvoieFormulaire(sFormulaire, sUrlPageAWP, httpPost) = Faux ALORS
Erreur("Echec de l'envoi du formulaire : ", ErreurInfo())
SINON
SI ExtraitChaîne(HTTPDonneRésultat(httpEntête), 2, " ")[[1]] <> "2" ALORS
Erreur("Erreur HTTP :", HTTPDonneRésultat(httpRésultat))
SINON
sResultat = HTTPDonneRésultat(httpRésultat)
SI sResultat <> "OK" ALORS
Erreur("le formulaire n'a pas pu être traité correctement", ...
"erreurs rencontrée(s) : ", sResultat)
SINON
Info("Données et fichier envoyés avec succès")
FIN
FIN
FIN
//-------------------------------------------------------------------------
//-- Code serveur du lien "LIEN_VALIDE" dans la page AWP WEBDEV
//-------------------------------------------------------------------------
bufRetour est un Buffer
 
// Vérification des champs reçus
// Fichier à uploader ?
SI SAI_UPLOAD = "" ALORS
//non
bufRetour += [RC] + "Pas de fichier à Uploader"
SINON
// Récupération du fichier uploadé
// UploadCopieFichier(SAI_UPLOAD....)
// Autres champs du formulaire
SI SAI_NOM = "" ALORS
// Récupération du nom ...
bufRetour += [RC] + "Pas de NOM"
SINON
bufRetour += [RC] + "OK"
FIN
FIN
 
// Réponse
ChaîneAffiche(bufRetour, "text/plain")
Envoi d'un formulaire (méthode HEAD)
sRecherche est une chaîne = "pcsoft"
HTTPCréeFormulaire("Recherche")
HTTPAjouteParamètre("Recherche", "hl", "fr")
HTTPAjouteParamètre("Recherche", "q", sRecherche)
HTTPAjouteParamètre("Recherche", "btnG", "Rechercher")
HTTPAjouteParamètre("Recherche", "meta", "")
SI PAS HTTPEnvoieFormulaire("Recherche", "www.google.fr/search", httpHead) ALORS
Erreur("HTTPEnvoieFormulaire a échoué avec l'erreur suivante : " + ErreurInfo())
SINON
bufBres est un Buffer = HTTPDonneRésultat(httpRésultat)
SI Taille(bufBres) > 0 ALORS
Erreur("Buffer résultat")
FIN
FIN
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire