PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Crée la base de données d'un compte client pour un site SaaS.
Remarques :
  • L'utilisation de cette fonction nécessite d'avoir ouvert une session d'administration SaaS au préalable en utilisant la fonction SaaSAdminConnecte.
  • Versions 16 et supérieures
    L'utilisation de cette fonction est réservée à l'Administrateur SaaS. Un gestionnaire de compte client ne peut pas utiliser cette fonction.
    Nouveauté 16
    L'utilisation de cette fonction est réservée à l'Administrateur SaaS. Un gestionnaire de compte client ne peut pas utiliser cette fonction.
    L'utilisation de cette fonction est réservée à l'Administrateur SaaS. Un gestionnaire de compte client ne peut pas utiliser cette fonction.
Exemple
S est un saasSite dynamique
C est un saasClient dynamique

S = SaaSAdminChercheSite("Forum")
C = SaaSAdminChercheClient("Hybrid")

SI SaaSAdminCréeBaseClient(S, C) = Faux ALORS
SI SaaSAdminCréeBaseClient(S, C, Faux) = Faux ALORS
Erreur("Impossible de créer la base client.")
SINON
Info("La base a été créée vide.")
FIN
SINON
Info("La base a été créée depuis la base de référence.")
FIN
Syntaxe
<Résultat> = SaaSAdminCrééBaseClient(<Site SaaS> , <Compte client> [, <Base vide>])
<Résultat> : Booléen
  • Vrai si la base cliente a été créée,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Site SaaS> : Variable de type saasSite ou chaîne de caractères
Nom de la variable de type saasSite (ou nom du site) correspondant au site SaaS pour lequel la base doit être créée.
<Compte client> : Variable de type saasClient ou chaîne de caractères
Nom de la variable de type saasClient ou nom du compte client SaaS pour lequel la base doit être créée.
Si ce paramètre est une chaîne de caractères, elle peut représenter le nom ou la propriété RéférenceExterne du compte client.
<Base vide> : Booléen optionnel
  • Faux (valeur par défaut), la base de référence sera copiée pour créer la nouvelle base de données.
  • Vrai, la base de référence définie pour le site sera ignorée et une base vide sera créée.
Composante : wd270com.dll
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire