PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Conditions d'utilisation
  • Actions réalisables sur une archive multi-parties
  • Actions réalisables sur une archive mono-partie
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Renvoie le type de l'archive : archive mono-partie ou archive multi-parties.
Exemple
MonArchive est un zipArchive
 
// Ouverture de l'archive "MonArchive"
ResOuvreArchive = MonArchive.Ouvre("D:\Sauvegardes\Sauvegarde.zip")
 
SI ResOuvreArchive = 0 ALORS
...
FIN
// Archive mono-partie ou multi-parties ?
ResEstMulti = MonArchive.EstMulti()
// Affichage du résultat
SI ResEstMulti = Vrai ALORS
Info("L'archive est multi-parties")
SINON
Info("L'archive est mono-partie")
FIN
Syntaxe
<Résultat> = <Archive>.EstMulti()
<Résultat> : Booléen
  • Vrai si l'archive est multi-parties,
  • Faux si l'archive est mono-partie.
<Archive> : Variable de type zipArchive
Nom d'une variable de type zipArchive correspondant à l'archive à manipuler.
Remarques

Conditions d'utilisation

  • La recherche du type d'archive peut être réalisée uniquement si l'archive existe (la création d'une archive s'effectue avec la fonction <Variable zipArchive>.Crée).
  • Cette fonction est disponible pour les archives au format WDZ, ZIP et 7z.
LinuxiPhone/iPadWidget IOSMac Catalyst Rappel : Seules les archives au format ZIP, TAR et TGZ (TAR.GZ) sont disponibles.

Actions réalisables sur une archive multi-parties

Certaines fonctions d'archivage sont utilisables uniquement sur des archives mono-partie (ajout et suppression de fichiers, création d'un exécutable auto-extractible, ...). Pour effectuer ces opérations, il suffit de regrouper les sous-archives (<Variable zipArchive>.Regroupe) pour obtenir une archive mono-partie.
A partir d'une archive multi-parties, il est uniquement possible de :

Actions réalisables sur une archive mono-partie

Toutes les fonctions d'archivage sont utilisables sur des archives mono-partie, exceptée la fonction <Variable zipArchive>.Regroupe (permettant de regrouper les différentes parties d'une archive entre elles).
Composante : wd280zip.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire